MACHIN3tools

No idea, I don’t use Quick Favorites. Maybe via the API?

Can’t reproduce this, and I doubt it’s related. It’s just sets the ALT + R keymap, which doesn’t interfere with ALT + LMB navigation.

1 Like

awesome! thank you kind sir.

1 Like

How do I toggle smooth with Korean Bevels? It’s not well covered in your documentation.

it’s alt + tab so if you are on windows you will need to remap it

I did and activated it but I don’t think it worked right.

well i mean it works fine,
https://ss.lamia.io/i/2021-05-07_15-57-56.mp4

1 Like

Though I’ve been using them myself too, first time I heard the term “korean bevels” was through you Machine. Curious to ask, where/when or how was this term created?

1 Like

There are google hits going back almost 10 years: https://www.google.com/search?q="korean+bevel"+polycount

The more you know…

2 Likes

yep you were confusing me likewise with that “korean” bevel term, this is called afaik triple edge support loops, or fencing bevels…

Again though, this isn’t a term he came up with himself. This is something people have been using since way before, all over the internet. And, frankly, I’d much rather write “korean bevels” than “triple edge support loops”…Life’s too short for that :stuck_out_tongue:

Sorry for derailing the thread btw, won’t touch the topic again.

1 Like

or just fencing bevels…

Loving the Deus Ex Version. Brilliant addition, worth every penny.

3 Likes

@MACHIN3 Is it possible to change this? MACHIN3tools’ Modes Pie alters my X-Ray settings when switching between Object and Edit mode. When modeling in Solid Shading, I prefer to have X-Ray On with 100% transparency in both Object and Edit modes, but it auto switches X-Ray to OFF and 50% transparency …

There is an Passthrough/Occlude toggle, that does exactly this for you, and it will switch off XRay again, when leaving edit mode.

Edit: There is no way to not turn off xray when going back into object mode, right now. I’ll make it a preference.

Edit2: What’s the point of xray in object mode at 100%?

When you exit Edit mode, with X-Ray On, more often than not you’ll want your models to be non-transparent in Object mode. Leaving X-Ray turned on in Solid Shaded view and cranked up to 100% makes X-Ray behave more like before 2.8, which is arguably a better way.

1 Like

Machin3, do you think it would be doable for a future DeusEx update to combine the align tools with the Edge Constrained Transform, so that one could snap partial or full loops to the X/Y/Z axis where possible?

I don’t follow. The Occlude/Passthrough toggle in the Modes pie already achieves this, and so does the edit mode Wire toggle in the Shading pie.

So, use the two xray approaches I have added for this exact purpose.

1 Like

Still a bit fresh in Blender, I’m following a course on Udemy (The Blender 2.8 Encyclopedia) where this advice originates from. For copyright reasons I can’t include the video but I’ll leave a (massive) transcript at the end of this comment.

My comment was meant to reflect on the fact that the Modes Pie didn’t allow me to follow his advice
(X-Ray On at 100% in Object mode; effectively meaning no X-Ray in Object but full X-Ray in Edit) since the Modes Pie affects the X-Ray setting by turning it off and resetting the value to 50% each time I change modes. Admittedly, I might have missed a valid reason for this to occur – but maybe this could be a user option?

Here’s how I’d like it to be when switching modes, which above technique accomplishes:

screen_20210516203106


Lengthy transcript from Udemy course, “The Blender 2.8 Encyclopedia”, Ch.18 - Viewport Shading, presented by CG Masters’ Chris Plush (Link: https://www.udemy.com/course/the-blender-encyclopedia/learn/lecture/18650196#overview - timecode 9:22). Pardon the puke inducing mass of text, I tried to truncate it as much as possible:

One. Last. Time: Use the Occlude/Passthrough toggle in the Modes pie.
How is this so hard?

1 Like