MACHIN3tools

add-ons

(TitusLVR) #61

Indeed! I have to try it.


(FreeAccess) #62

Hi,

For Windows users:

Using the program “grepWin” is very powerful… :+1:
In a few seconds, all your changes are made …

https://tools.stefankueng.com/


(radi0n) #63

Hello,

i rename all (grepWin found two) ‘.user_preferences.’ to ‘.preferences.’ and addon still dont work with latest (blender-2.80-e5e885d0ecb9-win64) build.


(FreeAccess) #64

Hi,
Many errors … there are 15 lines to modify… :smiley:

… and after that, it’s OK :+1:

and do not forget to change the name of the directory “MACHIN3tools_master” to “MACHIN3tools” …

Merry Christmas! :santa:


(MACHIN3) #65

Not necessary anymore. Just install from zip.

Official fix is going out tomorrow. I appreciate you guys figuring this all out on your own and sharing the info! Great to see.

Merry Christmas.


(MACHIN3) #66

v0.3.4 is out | Gumroad | BlenderMarket

  • SavePie - Append Materials
    • add Populate tool to fetch material names from source blend file

    • add AddSeparator tool

      • adding a “-” to the end of a material no longer works, separators get their own entry in the list and can be moved around like any of the material names
    • automatically add a material name, that is typed in manually, once return key is pressed

    • fix error in Append menu, when appendmats collection is empty

  • adapt to API changes
    • fix context.user_preferences errors
    • fix overlay.show_backface_culling errors
    • fix cursor keymap error
  • update theme

(MACHIN3) #67

This very much looks like you have another version of it already installed and activated. Make sure that is not the case and try again.

If it still fails, try on a a factory reset Blender and report it here again.


(David Schultz) #68

I have the exact same errors - even after resetting Blender to factory settings.


(MACHIN3) #69

Show me, record a video of your installation process please.


(Lee Hinds) #70

Tried a few things and it didn’t work out. However, your update plus downloading the 27th 2.8 build seems to have fixed it. That might also work for david_schultz

Thanks a ton!


(FreeAccess) #71

Hi,

For me… :+1:

Operating System: W7 64Bits
Blender Build : e4dbfe0a98c1 / 27-12-2018
MachinTools : Ver. 0.3.4

Process:

  • Eventually delete an old version.
  • Save Preferences
  • Restart Blender
  • Normally install the new version from the ZIP file and active it
  • Save Preferences

For now no problem . . . :smiley:


(David Schultz) #72

I was able to install it on a fresh install of Blender. I’ll set things back up and see if I can get everything working again. Thanks for the tools!


(MACHIN3) #73

Okay, if anybody encounters this issue again, I’ll have to release a debug build with additional output to really hone in into what is going on.


(MACHIN3) #74

Okay, I think I figured out what was happening with the “already registered as a subclass” errors.

Basically, this is not the root of the problem. This error is preceded by the “user_preferences” api change error, which none of you told me about in this context. So there are 2 different errors.

This is what happend:

  • 0.3.3 release was attempted to install and activate on recent blender build
  • activation failed, error was thrown about user_preferences not being found
  • at this point the activation didn’t finish, yet some of MACHIN3tools classes were successfully registered anyhow
  • you clicked the activation button again, which threw the “already registered as a subclass” error

Solution:

  • install latest blender build
  • to be safe, uninstall any previous MACHIN3tools version
  • install the latest MACHIN3tools 0.3.4 which fixes the user_preferences error

(radi0n) #75

Hello,

When i try to append material from ‘Materials Source .blend’ i have this error:

“The file path does not exist
Error: Material ‘Red_Plastic’ could not be appended.
Make sure a material of that name exists in the material source file.”

Material Red_plastic is in the materials.blend file.


(MACHIN3) #76

Your blend file path is wrong. Post a screenshot of your prefs please.


(radi0n) #77


(MACHIN3) #78

Make it an absolute path


(radi0n) #79

HA! Now is work like a charm! Thank You!


(MACHIN3) #80

I’m gonna enforce this with the next update.

Also, I’ve just noticed appending ALL materials is currently broken,