MACHIN3tools

add-ons

(radi0n) #142

bpy.ops.machin3.cursor_to_origin() - Thank You!


(Nomo) #143

Did focus change? I remember that it remembers the objects in isolation before a second focus. Now if I use focus without anything selected, everything appears on the scene.


(TitusLVR) #144

Super cool addon, i wonder how you do such complex addons like decalMachine and meshMachine. And i’m waiting MeshMachine for 2.8. It will be huge modeling boost in my workflow. Thank you.


(MACHIN3) #145

Blender changed. If you go back to the release from Feburary 28th or earlier, it’s still working. Newer than that and what you describe happens. Investigating. Thanks.


(MACHIN3) #146

You can help, by confirming this bug/issue on the tracker: https://developer.blender.org/T62388


(Nitram_2000) #147

Is there any way that you can make the materials append drop down menu contain sub menus?

Say I have 5 wood materials in my material blend, as well as 5 metals, rather than have a single list with 10 materials, one could have just 2 sub menus entitled wood and metal with the relevant materials contained within.


(Shunke) #148

v0.3.7 does not work with the latest Blender 2.80 build ( March 12 ).
It works fine from the build on March 4th.
But it may be too much asking for MACHIN3 to fix the bug for every dayly builds.


(MACHIN3) #149

Works fine for me. Please post your complete terminal output.


(MACHIN3) #150

The windows builds are 2 commits ahead, and right in between there’s a breaking change. I’ll have to wait until the linux builds have caught up.

FWIW, always post the version hash, if you refer to a blender build. 6b39dc7672eb is broken, e6eb7b9ccee1 is not.


(Shunke) #151

The build which gives the error is " blender-2.80.0-git.6b39dc7672eb-windows64 ".
The build which works fine is " blender-2.80.0-git.e5ab2b9c629e-windows64 ".

I tried to re-install MACHIN3tools but it gives me an error when activating it.
message is this

Info panel shows this

info

I hope this helps.


(Giakaama) #152

Agreed Hash: 6b39dc7672eb, gives errors trying to activate MACHIN3tools .


(iceythe) #153

https://developer.blender.org/rB3017d88aec7f3f44ba9db930920ac2a51aef750d

There’s a recent commit that renamed XX_YY_specials to XX_YY_context_menu for many if not all categories.

I’m just gonna throw out a number and say that this breaks 100% of all addons that tries to append to specials menu :stuck_out_tongue:


(Giakaama) #154

Yeah this is it . Replacing all the recurrences of “specials” with “context_menu” works … Now looks weird … :slight_smile: function example : remove_object_context_menu_menu() … that menu_menu stuff :slight_smile:


(MACHIN3) #155

v0.3.8 is out | Gumroad | BlenderMarket

  • Focus
    • rewrite, use new local_view API tools
  • Align
    • add Origin and Cursor align modes
  • fix registration issue due to recent API change

(Giakaama) #157

A renaming tool could be cool :slight_smile: .


(MACHIN3) #158

You can rename objects from the shading pie.


(Ben H) #159

After installing 0.3.8 when I attempt to enable the add-on I get the following error:

Traceback (most recent call last):
  File "/Users/admin/Projects/blender-build/build_darwin/bin/blender.app/Contents/Resources/2.80/scripts/modules/addon_utils.py", line 351, in enable
    mod = __import__(module_name)
  File "/Users/admin/Library/Application Support/Blender/2.80/scripts/addons/MACHIN3tools/__init__.py", line 35, in <module>
    from . utils.registration import get_core, get_tools, get_pie_menus, get_menus
ImportError: cannot import name 'get_menus' from 'MACHIN3tools.utils.registration' (/Users/admin/Library/Application Support/Blender/2.80/scripts/addons/MACHIN3tools/utils/registration.py)

(MACHIN3) #160

Try again on a factory reset Blender. There’s no reason for this to happen, unless your registration.py is corrupted.
How did you install it?


(Ben H) #161

Factory reset worked, thanks!


(Nitram_2000) #162

I updated to the latest version of 2.8 and also the Machin3Tools and now the Modes pie doesn’t open. Has this happened to anyone else?

Edit: The Shading Pie is also not fully functional.