MacOS X and Windows compatability problem

Hi guys. At work, I use a Mac. I am running Panther, and Blender works GREAT. There is also a PC running Windows XP that I sometimes try and transfer .blend files to, but I run into some problems. The biggest is windows hadling of Quicktime files. Now, I can add animated textures in the Mac Os X environment that are in quicktime format, but when I transfer my .blend file to the PC, it does not recognise those textures and I get an error that reads: not an anim!

Also: I use Adobe After Effects, Photoshop, and Final Cut Pro at work, so the quicktime format is the foundation for EVERYTHING I do. There are little to no problems if I am working solely in a Mac Os X environment… BUT: when I try to export a quicktime from a PC, I get a file that is 0KB is size, and fails to open in ANY media player. This PC has got all the necessary Quicktime codecs installed, but Blender fails to output to this format on the PC. is this a known bug? Does anyone know what could be going on?

Would appreciate the help. Am trying to integrate Blender into the workflow around here at work.

strange, i was able to export quicktime (DV-PAL) and also load it as a texture on XP. i use the intel optimized 2.34 and quicktime 6.5.1.

did you try different codec settings? maybe that could help. as i said, when working with quicktime, i mostly use the DV format, which seems to work on both plattforms well.

sorry can’t tell you more… any more hints/information from your side?

mairn

Sure: The quicktime version is the latest: 6.5.1 The animated textures have been rendered to the animation codec - millions of colours. I’ll try the DV PAL setting. Maybe that’s the trick.

Out of curiousity - how do you use Blender at work?

Well, I have been using Blender for my own projects up until now - waaay back since version 1.8x. Recently (well - January), I began work as a video editor in North Sydney. We use Final Cut Pro to edit our productions (TVCs, corporate videos, TV interstitials, etc). We mainly use After Effects and the Adobe family of programs to do our graphics. Recently, however, we were required to ‘build’ a toon set for a disney morning program. I suggested this program, and made the set. My boss was so impressed we gave me the client and the work, and I created a whole toon town, virtual studio, and flew a camera through it. We incorporated the 3D graphics with 2d elements (added in After Effects) and then mastered the whole thing to DigiBeta for the Disney Channel.

So you could say I use Blender to create 3D elements for graphics intensive projects. Right now, the main encumbrance is I can’t seem to output a quicktime with Animation codec and alpha. I seem to have to render an alternate scene with all objects set to a white texture on a black background. The file Blender exports when you hit the “PREMUL” button and set “RGBA” has a glitch - after effects, FCP and QT don’t recognise its alpha channel - if it has one.

Hope this answers your question! :wink:

have you tried moving the quicktime file seperately thne putting them back into blender?

Have you tried TIF compression yet (within the quicktime settings)? If anything, that’s the one I’d try…

Failing that maybe you could set the background to pure pink in the world settings and set that as transparent so that you won’t need to go through the masking process?

I have a feeling that Blender may not export an alpha channel to video formats, only image sequences. In that case for shots with alpha, you’re probably best rendering to a TGA or PNG sequence which store an alpha channel quite easily. Saves trying to fake it with white and black textures. Generaly I find that ‘key’ alpha imports better into other programs than ‘premul’, too.

BTW: What’s the name of the place you’re working at? I’m just about to finish a freelance stint at LKS Design in Blue St. above the train station.

The work you do sounds very interesting. I agree with broken and just render to lossless images. PNG gives the lowest file size. When I used Maya, I was able to render alpha and depth information that way. Then you just open quicktime and go to file menu -> open image sequence. The files have to be named a certain way like image001.png, image002.png then you select the frame rate and you can save as DV, animation, whatever.

I always use that method because it’s far easier to repair broken frames or ones with artifacts.

Yeah, I tried a TGA and PNG sequence, but a strange thing happens - will post examples tonight when I get home. All 3D objects get assigned a clean alpha, but any planes that have PICTS or JPEGS with alpha, and are casting raytraced shadows, don’t. Instead, only the PLANE they are texture-mapped onto gets an alpha. So, for example: you have an upright plane with a picture of a tree on it, and that picture hase an alpha channel of its own. You make the sky texture blue. You export a PNG file with PREMUL and RGBA activated, what you get is a transparent background AROUND the plane. All transparent areas on the actual plane will be filled in with the sky colour. This is also true if the plane is infront of another object: you get a sky-filled square around your tree.

I’m sorry if I am confusing you, I need to post some pictures to show you what I am discribing.

btw, I downloaded 2.34 last week, and the windows version NOW exports Quicktimes NO PROBLEM! I tried it at home, and is all well. That’s one step closer to achieving a program that can be integrated into a workflow like I have at work.

The work you do sounds very interesting. I agree with broken and just render to lossless images. PNG gives the lowest file size. When I used Maya, I was able to render alpha and depth information that way. Then you just open quicktime and go to file menu -> open image sequence. The files have to be named a certain way like image001.png, image002.png then you select the frame rate and you can save as DV, animation, whatever.

Thanks for the comments. My bosses are thinking of switching to Maya very soon, because of its compatability with the Mac system. But they are extremely impressed with what I have achieved with Blender, too! I will be posting my examples of work very soon for you all to see.[/quote]

Ah, I understand what you mean, now. I ran a few tests here, and it seems that if your transparent object has RayTransp on, you get the problem that you’ve described, however using Ztransp works just fine. I personally can’t imagine why you’d need raytracing (refractions, etc) if it’s just toon characters on planes, so Ztransp should be just fine. I don’t know if this is a bug, or an inherent limitation in the raytracing system…

Here’s my test file: http://mke3.net/rt/ztransp_key.blend.zip

Ah, I understand what you mean, now. I ran a few tests here, and it seems that if your transparent object has RayTransp on, you get the problem that you’ve described, however using Ztransp works just fine. I personally can’t imagine why you’d need raytracing (refractions, etc) if it’s just toon characters on planes, so Ztransp should be just fine. I don’t know if this is a bug, or an inherent limitation in the raytracing system…

You need ray traced when you have a picture of an object that has to cast a shadow. Z-Buffer doesn’t seem to do this. But thanks for the heads up - I have had to produced an alpha matte the “hard” way, but duplicating all the objects on a scene and giving them a white texture that has no shading, and then doing the reding with a black sky. I have had to do all textured planes separately. Then I would composite the two “alpha” renders in AE with an “add” transfer mode. This would then become the alpha matte for the full colour render. If I set the Z-buffer, I would need shadows for this, and could do one alpha render…

But I wll try your way and see if it works for me!

Yes it does, have a look at my test file (which I stupidly previously mistyped the URL for, argh! ) : http://mke3.net/rt/ztransp_key.blend.zip

Or am I missing something once more? :slight_smile:

Cheers

Out of all the commercial software you could choose, I personally think Maya is the best. I prefer Blender’s design though and I would probably recommend using a modified version of Blender that allows the use of a more functional material editor like one that integrates with aqsis and allows Renderman programmable shaders. Maya is quite expensive and needs good hardware to run it properly. It also has a few bugs like manually entering vertex positions crashes it all the time for me - that was in version 5.

If your bosses do choose to use Maya, don’t get anything less than version 6, especially for the Mac. Earlier versions used CFM plugins, which are a nightmare.

I agree with you here. Broken’s example uses ray shadows too but it uses z-transparency. To use your example:

I got the same thing. There must be a problem with the raytracing. Like Broken said, it works if you use ztransp. You set your lights to use ray shadows but the transparent plane with the tree to be ztranp. I could see that being a problem if you had a glass material where you needed to use raytransp for refraction but ztransp will work for you.

Sorry if this is isn’t correct, but if you had a glass material that is refracting light with an alpha background, there would be nothing to refract anyways. You would still have to do the refraction in compositing anyways after you added the background, right?

Paul_C wrote:
You need ray traced when you have a picture of an object that has to cast a shadow. Z-Buffer doesn’t seem to do this.

Yes it does, have a look at my test file (which I stupidly previously mistyped the URL for, argh! ) : http://mke3.net/rt/ztransp_key.blend.zip

Or am I missing something once more?

Nah, not missing anything. In the toon environments which I have to create for this client, I don’t need refractions. I did try the z-trasp settings instead, and it worked fine! Thanks for the advice. Saves me a hell of a lot of work.

For future reference, however, the quicktime export settings still need working on. You are allowed to select (provided you have quicktime pro on your machine) the animation codec with alpha, but even with PREMUL and RGBA pressed, it will render out a video with NO ALPHA. This is evident when you import the render into After Effects, Final Cut Pro, Adobe Premiere, or any other video editing program that automatically detects the alpha channel of a file.

So: it’s rendering PNG sequences for me until this problem gets worked out.

:frowning:

[quote=“fakeplastic”]

Sorry if this is isn’t correct, but if you had a glass material that is refracting light with an alpha background, there would be nothing to refract anyways. You would still have to do the refraction in compositing anyways after you added the background, right?[/quote]

Ah you’re right. I was thinking that if you had an image of a tree but wanted it to look like glass you might use raytransp but I forgot that the alpha part of the image then refracts stuff too.

Which compressor are you using? There are few that support an alpha channel. The animation codec is the most popular choice. Quicktime DV-Pal doesn’t support alpha, check here:

I tried the animation codec out and I read you’d tried it before. To get it to show correctly in Final Cut Pro, I had to reverse the alpha. Not sure if that makes the alpha channel work correctly though.

Which compressor are you using? There are few that support an alpha channel. The animation codec is the most popular choice. Quicktime DV-Pal doesn’t support alpha

I am using the quicktime animation compressor, set to millions of colors+

When inported into After Effects, AE will detect that the file has an alpha channel and ask if you’ll like to IGNORE, use PREMULTIPLIED or STRAIGHT. It even gives you an option to guess. On ALL settings, however, I would get no picture, but set ti “ignore” and you get shown the picture, but the alpha isn’t knocked out. In Final Cut Pro HD, it will import, but not show alpha.

I tried the animation codec out and I read you’d tried it before. To get it to show correctly in Final Cut Pro, I had to reverse the alpha. Not sure if that makes the alpha channel work correctly though.

Yeah, I tried this, but in HD, it blanks out the WHOLE picture, as if the alpha channel is a 4:3 square. I also have seen the page you supplied the link for - I use the animation code for alot of stuff - not just 2d type stuff. Video footage comes out of after effects in surprisingly good quality (duh - it’s usually at millions of colors) and I only ever use it if I need something with an alpha channel; to key in a background later.