make all textures visible in UV-editor?

Hello, i need some finetuning with my bumpmap but i can’t make it visible in the UV-editor - only the colour texture.

Image -> Open ?

But where is the used bumpmap there?

Someone help me please - this must be possible in blender or?

i need to make my bumpmap, that i created in blender, visible in the uv-editor - how is this possible?

bump - i still need to know

You are not precise in your question.
Is it grey scale image or procedural texture.
If image - is it external or painted/baked in Blender.
Do you mean you cannot open/view image in ImageEditor?

Actually i don’t really know the differences between grey scale and prodecural,
but yes it is a blender internal created black/white bumpmap - i guess it is the prodecural thing.

The problem is that when i move my UVs in the UV-editor the bumpmap changes,
but i can not see how until the render because the bumpmap doesn’t show up in the UV-editor as background.

Do you mean you do not know differences between image ( just picture ) and procedural shader texture?
You cannot view procedural in UV editor because it’s created on-the-fly while rendering, and it doesn’t matter it’s bump or color map. It’s normal when you change UV map ( layout ) you have different result.
If you want to see it in UV editor you should use image instead of procedural. Maybe I missed something or maybe you should post .blend file as example.
Cheers :slight_smile:

That would explain it - thanks.

Anway i need to make it visible, so how can i turn that prodecural texture into a real image(that hopefully gives me exactly the same output).
I guess it has something to do with texture baking but i never made that so far, maybe someone can tell me how i get the best result for my needs…

Add simple plane, in edit mode hit U>Unwrap then in image editor create new square image as big as you need.
While in edit mode you should see in UV editor both image ( probably black square ) and UV map (layout).
Add material with texture you need, enable ColorRamp and set black and white at ends then menu Render>Bake Render Meshes>Only Texture.
In UV editor you should see result - save image or just pack as PNG into .blend file to prevent image disappearing.
Now you have image ready to use as bump or color map ( or whatever ) and you can see it in 3d view and in UV editor.
I hope it helps you.

When i use my existing UVs and just create a new image in the editor and do texture baking, i get exactly the result i wanted - thanks. Just the color ramps didn’t work for me
and i had to set the material to white and the texture colour to black. Unfortunately
the vronoi texture for example seems to come automatically with an alpha channel so that you can see always the material below.

It seems you left one of the color of ColorRamp with alpha=0.
You can set visibility of ramp colors via alpha slider under color input field.
Just set colors alpha to 1 with this slider.

But this only effects the material and not the texture. I can’t find a way to just make the vronoi texture visible - there is always an alpha value which makes the material below visible on certain areas. Anway i get 100% the same renderoutput with the baked texture and this problem is solved.


You can set for every position in ColorRamp individual alpha factor.
I didn’t mean under material color tab but under ColorRamp tab of texture.
When you set alpha=0 then this color is fully transparent and you can see material or any other color you put in shader tree.
When you set alpha=1 for all colors in ColorRamp you see this colors.
Link to BlenderWiki - see Texture Colors > Colorbands :

Arf, sry that window was hidden in dead space here - didn’t see it or know it.
Now everything works fine :slight_smile: