Make Back Faces Unselectable

During retopology, I have this annoying thing where I can select faces that have normals pointing from me. How can I disable that? Backface Culling does not help :slightly_frowning_face: :