Make hair particles cast shadows on emitter?

I am in the middle of working on this scene. I’ve run into an obstacle and it’s driving me crazy. I can’t get the grass (hair particles) to cast a shadow. I have completely checked both materials, and can find no errors. Does Blender not support hair shadows or am I doing something wrong. I’ve tried everything…Receive, Receive Transparent…etc. I’m not using Strand Render as the trees can’t cast shadow on the grass otherwise.


I think there is an option to use the strand primitive, which is actual mesh data. Also, you may want to look into deep shadow maps documented here http://www.blender.org/development/release-logs/blender-256-beta/other-rendering-features/