Make Instances Real - How to keep real objects in same positions as particles?

I set a plane to emit some particles. Then I used Apply->Make Instances Real to convert particles to non-instance objects. All the objects are in the same location. How can I make the resulting real objects keep the position they had as particles?

It should work as you expected. If it does not there might something other setting that is the cause.
You use an object as particle, right. Are there inheritions or modifiers or constrains on it? Check on child for it.

Rigoletto: Thanks. Good to know that it does work that way and isn’t a bug. I’ll look for things like you suggested.