Make mesh not scale/ get correct rotation with bone

Is there anyone familiar with rigify?
-After assign mesh weight to rigify bone, it can deform during bone moving, and it rotate in oddly way ( it kinda bit slower phase than the bone). How can I make that specific mesh not deform and rotate correctly. Below is a video for this problem:

-Here is a video I parent the bone to those object, no weight assign. I want it to look like this ( the object in leg still deform actually, I just use it here for illustration)

Here are the file:
untitled.blend (3.6 MB)

There are a few reasons, in the rig you linked, for what you describe.

One is that you have IK stretch enabled, so if you move the controllers so that the hands, feet, or head are too far from the body, they’ll stretch.

The other is that you have a bunch of bones that are bendy bones that probably shouldn’t be bendy bones.

I’m not very familiar with Rigify, so I couldn’t tell you how you got that second one, or how to tell Rigify not to set IK up for stretch.

1 Like