Make shadows on plane with Alpha set 0?

I need to have object cast shadows on a existing photo. When I turn down the alpha to show the photo, I lose the shadows too.
Is there some trick to get only shadow info, and the rest of the plane thinks its like glass?

Thanks,

First check Z-Transp, then set the texture materials to ALPHA, and move the alpha slider to 0 (in the materials tab), also make it shadeless =)

That did not seem to get it. Alpha 0 still removers every thing, including shadow info.
Hummm.

Hi,

Keep alpha at 1 and enable OnlyShad in the Shaders panel.