Make smoke dissolve very quickly?

Hello everyone. I am working on a muzzle flash. What I want the fire to do is shoot a tiny bit of fire and have it dissolve while constantly putting out a very small amount of smoke. The only problem I am having is that after I have the fire shoot out quickly, it doesn’t dissolve. I have the dissolve option turned down to its lowest. Solutions?

What do you use as an emitter ? A mesh or a particle system ? If it’s a mesh you’d have to keyframe the density of the smoke in the mesh physics panel. But maybe a particle system will work better for your muzzle flash.

Okay, I set the emitter to a particle system and it looks good but now I have another problem. Let’s say I want the muzzle flash to repeat rapidly. After the first muzzle flash, all of the particles are gone and I can’t get them to reappear.

Ok, so then you have several options :

  • you can use multiple mesh emitter along with some force fields to shape your muzzle flash and then keyframe the density on and off;
  • you could also use multiple particle systems, like duplicates of the original with different start values;
  • you could also try to create an image sequence of black and white images and use it as a particle texture set to density;

I think the second one would be easiest. Now, after I set up the different particle systems, how do I change the particle system the smoke simulation uses mid-simulation?

Oh boy, I didn’t think things thru. Sorry about that. You can’t. I did some testing and research and the image sequence thing won’t work either, it is a known issue, too bad as it was really easy to setup. Now, I’ll let you with two options for this effect:

  • multiple mesh emitters as I have explained above;
  • (probably the best one) make your particle emit continuously, and keyframe the density of the smoke of the smoke emitter, that works like a charm;

no matter which option you use, maybe you thought about it, but to make your life easier, while keyframing make sure that in the graph editor your keyframe interpolation is set to constant.

I hope you finally make it.

Alright! Changing the density did it! Thank you so much for your help!