Make texture transparent with screen blend mode

Hi,

I’m trying to composite a transparent texture that contains an explosion in front of a black plate. The plate has no alpha information so I’m trying to make it transparent by using the blend options in the texture panel.

However, my color does not seem to be as saturated as in the originally imported movie. What would I need to change in order to make it work and not loose color information?

Many thanks

Attachments


screen_transparency.blend (675 KB)

The .blend file does not have the Quicktime movie embedded. Go into File - External Data - pack into .blend file and then upload it here again please (if it does not get too big of a .blend file).

Here we go again. Please note that this is a compressed rar archive. You need to rename the file (remove the .blend) and unpack it to get the original .blend. The file was 1.21MB, but you are only allowed to upload about 950KB.

Attachments

screen_transparency.rar.blend (252 KB)

Still no packed files. Try putting the file in the Video Sequence Editor or just send the .mov through here as well.

I edited the post because I was not able to upload the real .blend as it was larger than the forums restriction. Please have a go again.

I didn’t find the options for transparency in 2.5x as they were in 2.4x, because the video does not have an alpha channel. The solution I’m thinking is for you to do a black and white copy of the video and use that as an second texture which will be used as the alpha value.