MakeHuman on OSX?

I d/loaded the OSX version(?) of MakeHuman but cannot find any information on how to get it running. The text file that comes with it says to select the directory in C:/ then run the .exe file - needless to say this was’t written for Mac users even though it ships with the Mac download:(

I did gamble and double-click the Unix file which fired up the command line but returned an error:

tcsh: Badly placed ()'s.
[path etc…] /Documents/DESKTOP\ STUFF/DOWNLOADS/Makehuman/makehuman_08_beta_OS_X/makehuman; exit
dyld: /Documents/DESKTOP STUFF/DOWNLOADS/Makehuman/makehuman_08_beta_OS_X/makehuman can’t open library: /sw/lib/libpng.3.dylib (No such file or directory, errno = 2)
Trace/BPT trap
logout

I tried launching from the application folder (in case it didn’t like spaces in folder names) but the error still occurs.

The MakeHuman site at Sourceforge doesn’t appear to have any info (and searching here is useless since the engine ignores “osx” so it just returns everything relating to MH) and I’m next to useless with command-line stuff and libs, etc. So, can MH be used on OSX at all? If so, any advice welcome.

/sw/ is the path that fink installs to on os x.

You could try installing fink and then installing libpng through fink.

I have used makehuman on my iBook, so yes, you can use it on Mac OS X.
From the errors above… do you have “fink” installed? have you installed the libpng? If not, that’s where you should start.

Secondly, I recall that it wasn’t very simple to run it. I used Terminal and I think I had to navigate to the very directory where the makehuman binary was located or else it didn’t find the base mesh. I can’t recall right now. I’ll test it again later today and give you a more detailed instructions.

Before you do that, you need the DevTools to be installed. otherwise, no fink.

I can’t confirm this, because I always have devtools installed, but would you need devtools for fink binary packages? I suspect you only need the devtools if you want to compile unstable packages in fink (or stable ones–but there are usually binaries of those).

Honestly, I don’t know. I remember that previously at least you had to have DevTools. And I think you need to do minimal amount of compiling even when selfupdating fink since it depends of other packages which are not in binary tree. But don’t quote me on that.

[EDIT: Re-reading the FAQ at fink page it does look like you should be able to use binary only. But I use the “mixed” method and at least I have had to use source code for many things. To be safe, install DevTools. If you have very little space, and want to try, try if the binary only mode works for you, but if it doesn’t work out, don’t blame me for gray hair] :smiley:

Okay thanks for that. I’ll put it all in the too hard basket for now and come back to it if I ever think I really need it - or when there’s a ready-to-run binary.

It would be nice if this info was readily available to users before download. It’s a shame to have people working hard on something like this yet not offer simple advice to would-be users (I clicked on a number of links on the site but the only “help” page I found began with “this info is for Windows only” :frowning: - and Google turned up nothing useful, even with the error message).

Unfortunately this is the treatment many free source projects give.
If you’re lucky the README has a Mac OS X section, if you’re really lucky it might actually say there [such as “This part of the README is not finished yet”] and if there are instructions they usually go aline “type ‘make’ in the terminal” and zero information what to do if the make fails.

I’ve made up my mind that prorammers are all asshats :smiley:

It ran fine for me.

I have libpng installed in /usr/local/lib though. Fink isn’t needed.

What I had to do to get it to run though was to open the terminal and type cd then drag in the makehuman folder and hit return. Then type:

chmod 755 makehuman

to make it executable. Then type

./makehuman

If you still get the error about libpng, I’ll upload a binary and you can copy it to the appropriate folder.

I agree wholeheartedly. This “holier-than-thou” attitude of the open source community coupled with the elitist attitude of those who have “FR” the “FM” makes me really, really glad there there is a legitimate, more efficient alternative to Windows in OS X.

If Open Source was all there was I think I would have gone back to a word processor and a sketch pad years ago…

Firefox, Blender, and other poster children for the open source movement are shining beacons of how things should be done, too bad the rest of the projects can’t see that. They just sit there wondering why Ubuntu has not taken over the desktop. If Ubuntu is the best of what Open Source has to offer on a desktop, then Apple and Microsoft have absolutely NOTHING to worry about.

But, enough with the rant. You guys that got this up and running, could you put together a CLEAR step-by-step account of everything you did to get it running? It would really benefit a bunch of us I’m sure. Well, at least me, who plans to try makehuman in the not too distant future…

Hey, I didn’t intend this to be a slap for the developers. I’m sure they’re all busy doing whatever they’re doing. I just think it’s unfortunate when documentation is non-existent - or wrong. What the developers probably need is some volunteer documenters.

I guess I see it as kind of pointless to severely limit your user-base due to the lack of a few simple words telling the less “geeky” among us how we might get the thing to work.

I’ve had the same problem installing Python 2.4. It installed easily enough but since it doesn’t appear to replace 2.3 I was unable to tell if it was actually doing anything. There were a couple of odd things in the application folder with no accompanying explanation so I didn’t know if I was supposed to do anything with them or not.

I’m sure in the early days of development, it is easier to limit users to those who understand the fundamentals but MH seems ot have developed far enough to allow average users to take part.

My description wasn’t clear enough?

OK,

  1. download the package from http://prdownloads.sourceforge.net/makehuman/makehuman_08_beta_OS_X.zip?download
  2. unzip it
  3. use the terminal to move to the unzipped directory by typing cd and drag the folder into the window (this saves typing the path) and hit return
  4. type chmod 755 makehuman (the tab key will autocomplete the word make human so you can type m then tab) and hit return - this just sets the execute permissions
  5. type ./makehuman (again autocomplete using tab) and hit return to run it

If you still get an error about libpng in the console (/applications/utilities/console), let me know

Osxrules,

Exactly, the detailed steps such as “chmod 755 makehuman” are always missing. THAT’S how clear instructions have to be for those that don’t know what they’re doing. It’s technical writing 101.

AndyD,

The Open Source community in general seems to assume that the documentation is irrelevant. We need to complain. We need to complain because telling us HOW to use a product is 50% of getting us to use a product. They are royally screwing themselves over by not documenting things better, because that means more people give up before the product is installed, and that in turn means fewer people using it, and a more negative attitude towards open source.

I love the idea of open source, but with the exception of the aforementioned standout programs, the execution is pathetic. I don’t care what developers think, because without the end user, us, their product has no purpose whatsoever. Yet, they in general don’t seem to give a damn about the end user, and the l33t script kiddies hanging out on forums and IRC seem to have “RTFM LOLZ!!!111” set up as a macro. Yeah, that’s helpful…

It’s easy to forget that here since the official Blender forum is filled with knowledgeable people willing to help. This site, and Blender in general, are NOT par for the course…

Sorry if I’m ranting, the last few months of my life have been lost to a Linux/open source CRM configuration nightmare that really showed off how little progress has been made in the mentality of the community. Luckily that’s all past now, but the frustration will take a while to dissipate…

Thanks OSXRules. Unfortunately, I still get the following error.

dyld: ./makehuman can’t open library: /sw/lib/libpng.3.dylib (No such file or directory, errno = 2)
Trace/BPT trap

Here’s an installer for libpng:

http://www.geocities.com/ajr650/libpng.pkg.zip

It should work after installing that. Don’t worry about the version it says, it does install the version you need. The installer came from a 2D vector animation package called Synfig Studio.

Well there you go - it looks like we have lift off!

Thanks as always.

BTW: Is there a simple online resource introducing long-time Mac users to the wonders of the Unix underbelly? Back in the old days, I used to “enjoy” messing around with MS-DOS but since convertting to Mac over ten years ago, I really haven’t thought much about what’s going on underneath the OS. OSX and open-source keep bringing it all back to the surface though.

Something like this might help:

Usually you can just follow standard Linux tutorials. I’ve figured out a few problems by following Linux instructions. OS X just uses the bash shell so most things are exactly the same as using the bash shell on other platforms.

You bash profile is in your home folder so you can put aliases to commands in there as well as install command line tools. You can edit it by using open -e ~/.profile

To add commands, you can just add directories to your path variable. If you download the command line rar program, it’s not very good having to change directory to the rar folder and run it from there so you can do something like this:

export PATH="$PATH:/Applications/rar"

This just adds the path to the rar binary - make a new temrinal window to make it work. Now I can unrar from anywhere. One of the most useful ones to do is to add /usr/local/bin because a lot of apps install their binaries there. Step by step:

  1. type tab twice to see how many commands you have
  2. type open -e ~/.profile
  3. type export PATH="$PATH:/usr/local/bin"
  4. save.
  5. open a new terminal and type tab twice to see how many you have now

If you right click Mac apps and then select show package contents, you can see the unix style binary in /Contents/MacOS. You can sometimes launch this from the command line with a ./<name>. You can launch Blender this way and if I recall from the source code, it takes some command line options.

You can find a lot of information just by looking at the unix man pages.