Making a realistic carpet

I’ve spent the last 3 days trying to model a realistic carpet using particles. But no matter what setting I use, the carpet just doesn’t look good. I’m trying to create a carpet like this one:


Source: http://www.combatcarpetcleaners.com.au/resources/Carpet%201.jpg

Basically a nice carpet that’s warm and runs all through the house. But there just doesn’t seem to be anyway to get this properly. The closest I could get is as shown in the following images:

http://img718.imageshack.us/img718/3426/weight1.th.png

http://img217.imageshack.us/img217/6527/weight2.th.png

http://img534.imageshack.us/img534/9519/renderq.th.png

and IMO, it looks pretty bad.

To sum it up, I have 2 questions:

1. How does one go about making a realistic carpet? I’ve tried with just a texture and bumpmapping it, but it looks really bad and paper thin. Is particles the right way to go about it?

2. If I use particles, how do I put objects on the carpet without having hairs of it stick through the object? As shown above, in my scene, I accomplished it using weight painting, but since weight painting can only be done on vertices, I needed to subdivide the floor several times to just make it barely and it doesn’t look that good either. It also makes the scene more complex. Any suggestions for this would be great.

after you made your fur look nice
(remember to save steps)
switch into particle-edit-mode
and tweak the hair…
for example with the “comb”-tool and
set for all hair-vertices (not only for the tip-vertices of the hair)
and proportional-edit-mode
and then
move the hairs down, like they are pressed down from the
chair, box, desk…
if you have large objects - like a locker - you can cut-off the
hairs for the area under this large object (less hair, less cpu-power…)

Thanks for the tip. Didn’t notice particle mode before.

However, I’m using children to fill it up and make it look nice and thick. But the particle edit mode doesn’t work on children. I’m using the interpolated mode since the simple children gives a large number of clumps. Any idea on how to effect it on children as well in interpolated mode?

Edit: Here’re my settings for the children, if it helps:

http://img855.imageshack.us/img855/9898/childrenw.th.png

try at the material repository
there are some carpet texture there

http://matrep.parastudios.de/index.php?action=view&material=58-bloodshot-eye

happy 2.5

Nopes, couldn’t find any good carpet material. I’ve tried using a carpet texture and adding bumpmaps and specular maps, but it doesn’t look as real as I want.

I’m trying another way using particles, using ‘dupli objects’, I’ll post back my results over here once I get something.

hi zanyman,

check this tutorial
http://bertrand-benoit.com/blog/2011/02/20/shag-carpet-using-forest-pack/

Thanks! I am currently trying to achieve something on similar lines, but your link does show a much more realistic carpet.

I think I will consider this carpet complete for now, this is as far as I could get. It’s been an irritating 2 weeks of trying to get it this far and with my laptop only having 3GB ram, I’m tired of Blender crashing with the particles. So, I’ll stop with the carpet here and go on and try to complete the rest of the scene. I know it’s not perfect, but it seems to work fine from a certain distance. Maybe I’ll do something more with it later, but for the moment, I’m calling it finished.

http://img822.imageshack.us/img822/4100/rendercarpetdone.th.png

Here’re the steps I used:

  1. Create a hair particle. This is what I used:
    http://img39.imageshack.us/img39/5527/hairparticle.th.png

  2. Use Hair particles and set the hair particle as the object.

  3. Use Particle mode and remove unnecessary hair particles that won’t show up in the scene.

  4. Set a carpet texture to the base and give it use the Color and Normal options to get the image texture mapped and also bumpmapped.

  5. Set the colour of the hair particle to that of the texture.