Making an object reflect the real environment around

Hi guys!
I’ve got into tracking a scene and adding computer graphic elements in blender, and now I have to insert a shiny object in my scene (a coffeemaker).
I have set a shiny material for my object, but since my object is alone in the scene, since i render it over a video i shot in real life, it doesn’t get the reflections.
I was wondering how could i make its reflections be like the reflections it would get in the real world.

The further i got was to create a cube around the object with the texture of my sequence, but I don’t know how not to render it and only its reflections…

Someone is able to help me with that? thank you guys :slight_smile:


on the reflection cube, go under the object settings -> ray visibility -> disable camera ray, that should hide it from camera view but still keep reflections

and where do I find these “object settings”? thanks

guys, can someone help me with that? thanks

go to object panel in cycles

then at the bottom of window there is the ray visibility sub panel
in there set the camera off for visibility

salutations

sorry again, but are you talking about the material panel under the properties editor or what?

yes big column on the right
with all the panel from render to physic

select the object one !

you should look at wiki pages to read the basic window set up at the beginning of the book
at least you would know usual names of windows and panels for blender GUI

salutations

guys are you sure? cause I really don’t see any ray visibility sub panel or camera off… im running blender 2.61
thats all what i see
http://img545.imageshack.us/img545/3188/schermata022455981alle1h.png

you need to be in cycles mode at top header


salutations

yeah, ok i switched to cycles and now i can see the option, it’s just that when I switch the rendering engine I get something really bad, all the work i have done with nodes can’t be seen anymore and all the objects are like stippled…

i was hoping there way a way just to make the object just reflect without changing anything, if not how can i fix this new render?

thanks


see lat pic for nodes

you need to split horizontaly your screen and set the top part for nodes editor
then it will show all the nodes like in pic

then in mat panel you need to add a new cycle mat and set it

now in cycle you can make your mat with glossy and select sharp then it will reflect a lot
but still need to add something for refleting on the objects

like
HDRI objects for sky or add several plane emission around your scene and set as no ray casting in object panel

salutations