Making camera see in texture shading [Solved]

I’m using blender 2.49b, and I have this fully textured model. When the ‘Viewport shading’ button is set to ‘textured’, the model looks exactly the way I want it to. However, when rendering, the model looks like how it does when it is set to ‘shaded’. How can I make it render the way it looks in my viewport? I have a picture to illustrate: http://i33.tinypic.com/25tvyoj.png.
It is also attached.

Attachments


the viewport doesn’t show specularity in textured mode, so i think you need to click “set smooth”, add an edge split modifier, and turn down the specularity a lot…

viewport show only the basic color even in Texture mode

render takes into consideration everything

so it will never be the same

this is to save time

you could Alt-P to open a preview window
but the bigger it is the more time it takes to render !

salulations

if the shading is exactly the way you want and you do not want the lights in the enviroment to change the way the model looks then you could set all materials on the model to SHADELESS.

Hmm, well I made his shirt Shadeless and the whole thing Smooth, but I don’t know how to set his Specularity or use an edge split modifier. Anyway, it seems neither setting Smooth or Shadeless is giving me the effect I’m looking for. Also, it seems important to note that clicking the ‘Render this Window’ gives me the proper effect, but I can see things like armature, which I’m pretty sure is not good. Attached the renders to illustrate.

Attachments



To change the specularity, you need to assign a material to it (materials>add new), then go to the specularity color and change it to a blackish color. then go to the modifiers (i use blender 2.5, so i’m not sure where they are, but i think they’re in the object panel) and press add modifier and change it to edge split (you may not have to use the edge split, i would render it without it first to see). Bear with me, I haven’t used 2.49 for a while, so i’m not sure if i gave the correct instructions or if there even IS an edge split modifier in older versions.:o

Well, turning off specularity seems to make it look better than before, but not quite what I’m looking for. (I think he still looks blocky, but setting smooth is too smooth.) Also, I don’t think the edge split modifier is doing anything.:confused:

Attachments


set ambiant levels higher, maybe use reduce reflectivity

Well, now I’m trying to make him one mesh, to make it easier to change material settings around and animate, but when I join him up, he looks fine in the textured viewport, but in the shaded viewport and when I render… what the hell happened, and how can I fix it?

Attachments


Bump Please, I don’t need to join him up like that, but how do I make him look like he should?

Attach your blend file to your post of if too large try another host site.

Okay, here’s the blend. It’s a bit crummy, but I just need it to look okay right now.

EDIT: Wait, my eyes were playing tricks on me. Turns out setting everything to ‘shadeless’ makes it look okay. I feel retarded. :o Since it looks okay now, I’m taking down the blend.