Making pipes using Dupliframes

I’m wanting to make pipes (i.e. looking like plumbing pipes) that travel in three dimensions at right angles to each other. I’m using the method described in the Dupliframes video tutorial.

I start out with a Bezier curve and make the curve “3D” by clicking the 3D button in the Curve and Surface section of Edit. I then hit the V key so that I can extrude straight lines. I then extrude straight lines in either the x, y, or z axis pressing the x (y or z) key to constrain the straight line in that axis. I then go through the process of creating Dupliframes (using a NURBS circle) as described in the video tutorial. When I skin the Dupliframes, the pipes in the x and y axis appear normal but the pipes in the z axis twist once making the z axis pipes look like sausage links. Am I doing something wrong or can this be corrected?

I’ve tried the method where you add a Bezier curve, make the curve “3D”, extrude it, then add a Bezier circle and then put the circles name in BevOb. I get a nice pipe in the x and y axis, but again, that annoying twist in the z axis. Any help appreciated.

I’m new to Blender, using Blender 2.35.

TIA

gannon

Possibly the “X Axis Phenomenon”

https://blenderartists.org/forum/viewtopic.php?t=11479&highlight=curves

See his “Role Played by X Axis” here:

http://membres.lycos.fr/bobois/index_anglais.html

%<

The above post should have read “z-axis” rather than “x-axis”

Also explained in the manual:
http://download.blender.org/documentation/htmlI/x4201.html

GreyBeard

Thanks Greybeard!

%<

I’m having a lot of trouble adjusting the axis of the NURBS circle to match the Bezier curve. When I get the curve set up and then add the NURBS circle, I select the circle, go to Object mode, highlight the Axis button. When I go to Anim settings and click the x, y, or z buttons to adjust the axis, nothing happens.

The links above show how you need to be careful to make the axis of the curve and circle aligned to avoid kinks in the z axis of the pipe, but they don’t show how to actually modify the axis so they are both aligned. I have the same problem doing it by dupliframes or by the BevOb method. I just can’t figure out how to actually align those axis.

gannon