Making things glow...

Getting back into blender after a very long break. I installed the latest version, re-opened the last project I’d worked on, and found some things had changed. Most noticably, was the removal of radiosity.

Previously, I’d managed to get the red eyes in this file nice and glowy. Now, they’re incredibly bright and don’t seem to cast much light anywhere, as can be seen here:


From what I’ve read, the environment settings are key to getting materials to be glowy and emit light.

The material has an Emit value of 2.000

Environment settings are:

Indirect Lighting: on
Factor: 1.000
Bounces: 10

Gather: Approximate
Attenuation:
Falloff: off
Strength: 1.000 (but it doesn’t matter of FAlloff is “off”)
Sampling:
Passes: 3
Error: 1.970
Pixel Cache: Off
Correction: 0.05

I’m not sure what to change or correct to get them nice and glowing like they were back when I had radiosity.

start first with only ID and not environment light and make sky black very dark

then set your emit value to 2 or 4

this will emit ligth like it was in radiosity for 2.49

then you can come back and play to adjust sky darkness or add a little environment light for general light in the scene.

you could also add a glow node to your object in composite nodes!

now if you can upload a sample file so we can play with it

salutations

this tutorial shows you how to make things glow using the compositor and emit values.
http://live.interwebsitedesign.co.uk/index.php/home

may be helpful.

After much playing around with lighting, environmental, and material settings, I got something a little better:


Still not 100% satisfied with it, maybe I’ll try some of the compositor-based fake-glow effects…

was the removal of radiosity.

Some break. Anyway, I’d add a glare node.

I started building up the environment and the eyes hardly seem glowy at all now (ok, I admit I did tweak them a bit too - for the better, I think, but it’s only noticable when the camera is focused on them so that they fill the final image). I may just replace them with little red lights… :frowning:


Hmm, I’m not 100% sure how to solve your problem, but are you set on using BI? Cycles has an emitter option that works great, and your scene should look great in it.

Cycles didn’t exist last time I played with Blender, so I’m a bit out of date. :wink: What does the Cycles rendering engine do differently?

It renders light differently,unlike the default light the cycles light bounces of meshes for a more realistic affect.

though that’s prob not all it does.

Basically, Cycles is a way more realistic approach to rendering. If you are not familiar with it, I would watch an example of things glowing or introduction. I think it would make your scene way better because of the more metallic look that you are going for, and the glowing parts would actually glow. I hope that helps!

Ok so here’s my first try using the cycles engine. Not bad, but very noisy:


Render settings:

Samples:
Render: 24
Preview: 14

Bounces:
Max: 14
Min: 4

(all others were default)

How else can I eliminate more noise.

shouldn’t the render be around 500-1000 samples?

crank the lighting up a little and render for around 500 samples initially; but by what i can see it looks good :slight_smile:

since your new to cycles you can find alot of helpful stuff on my cycles thread (its on the first page of WIP)
i like the scorpion, last night i was watching tranformers (the film not cartoon lol) and it looks alot like the transformer in the desert :slight_smile:

Ok, here it is again. This time, 250 samples. Also, I had to crank the lighting up to 18 000 … uh… units of light from 4 000 in the previous render. Of course, render time went from about 4 minutes to 43 minutes, and it’s still pretty noisy. :frowning:


Also, @bizla: Believe it or not, this model was first started in about 2007 or 2008 - whenever the “Array” deformation was first introduced to blender. The spiky “shell” of this thing was an experiment with the cool new tools - and then other things came up.

Nice model, but something wrong with your render settings, or you render with a pentium 3.
Don´t use a closed box environment, open one side or the top and setup the world with Sky texture or hdr image.
It is also possible to render with your GPU, if you have a newer nvidia card. Settings in User Preferences > System.
This example renders 30 Seconds on GTX 260 or 2.48 Minutes on my quad q6600.

Cheers, mib.

Attachments


monkey.blend (109 KB)

hmmm not sure if this is an accurate benchmark… it took 2:14 to render on CPU for me, and … it doesn’t render on my GeForce GTS 250, just renders on CPU (but maybe it’s not supported).

Well, you had a good tip about getting rid of the box environment: just removing the ceiling of the box took the render time down to about 7 minutes!

But… I do like the box environment look, and I was actually planning to decorate the ceiling after I was happy with the look of the walls. So is there a way to fake it that won’t drastically affect render time?

Also, the walls are made using the Array modifier. Would converting that to a real mesh have any impact on render time?

Latest render (with no ceiling):


Yes, GTS 250 is not supported.
In my file the box has two different materials. The top face has a emission material, the rest of the mesh is diffuse.
It is very hard to light a closed environment for a pathtracer, you could try to put one mesh emitter (or more) behind the camera, with low emission.

Also, the walls are made using the Array modifier. Would converting that to a real mesh have any impact on render time?

I think no.

Cheers, mib.

I found I could render the scene in about 10 minutes inside a box, I had to use 4 meshes with an emissive material as “ceiling lights”. Took a lot of tweaking to get something decent.


Undecided if I should keep the glowing blue parts.