Mantaflow Refuses to Produce Spray/Foam

Hello all!

I have been experimenting with Mantaflow for a few weeks now, but in all of my trials I have been able to get the particle generation to work.
The FLIP fluid particle system bakes perfectly fine (I generally use 64-128 divisions), mesh generation is well and good.
However, upon trying to bake spray, foam, and/or bubbles, it calculates just like any other bake and appears to work-- generating three new particle systems labeled “spray”, “foam”, and “bubbles”, but no matter what I try they all display “0 fluid particles in this frame”.
I have tried upres’ing my fluid, particle, and mesh simulations, and I have tried reducing the threshold for particle production.

Has anyone else experienced difficulty getting Mantaflow to produce these particles?
Any advice or experience would be greatly appreciated, thank you!

Try making your domain and object larger - it seems like there’s a bug with domains smaller than like 1m or 2m not behaving well.

Scale up and then Ctrl+A - Apply Scale and see if that helps.

Also you can always try starting over in a new file from scratch - sometimes that’s the best solution, ha.

1 Like

make sure the particles are rendered as objects and not halo