Mantaflow rendering issue

So i’m trying to render some work using mataflow and it renders fine in the viewport using eevee. But cycles appears black.
Final renders in eevee and cycles doesn’t show anything
other than the emitter.
My blend file can be sourced here https://mega.nz/#!JihF1LBI!9kKfR_YVj9t_KLGVJlWDj91imIuoxaAaw7GbbLJ0Ac0
Can anyone see where I am going wrong?

Crowds

I had a look at your file, you don’t have an emitter. I don’t know why the smoke shows up in the viewport but that works. Also when you switch from eevee to cycles and you look in the shader tab the material output has a selection for the render engine. The cycles version render out chunky while the eevee version is very faint.

AHH I was under the impression that once the SIM was baked you could delete the emitter to stop it appearing in the final render.
That said the problem existed before I removed it. I’ll have a look over what you mentioned about the shader when I get home tonight.
Thanks for your time.

Yeah, don’t know what the deal is with the emitter showing up in renders.

Sorted the emitters by copying them to a new collection . Amended file can be found > https://mega.nz/#!w7YnUApY!oVv36JLyghTa8dqBnLSLhh03oD-GZrmsnFwJo77x2ng
Ultimately I want to render out in eevee. I’m not even seeing anything remotely faint in the render :frowning:

When I enable the emitter collection and re-bake the sim I get the following in the color and alpha channels of the resulting render (frame 5). Following that is the render I think if you look closely you will see the volume. I have been trying to see what is causing this faintness but no such luck so far. The channels can be accessed as follows:

nebula-color nebula-alpha nebula-color-and-alpha

On thinking about this, two things may help.

Have you tried the object > quick effects > quick smoke to look at some standard settings and make sure you can render?

You can turn off the renderability of the emitter by going to the object tab > visibility > show in renders.

EDIT:

in looking around I found this post:

Lowering your Render Tab > Volumetrics > End to 90000 seemed to make the smoke show up better

Hmmm but its not even faint with me, it literally doesn’t render anything other than the emitter.

Sorry, didn’t see that you replied. I don’t really have any new ideas, but you re-baked with the emitter showing with the file in this post:

I just checked again:

Open nebulas.blend

Enable emitter collection

Select smoke domain

Free data (twice because it can’t find path)

Put new path

Bake

Move to frame 0 then frame five

Render

Get this in the color channel: edit:although the background in the render view is black:

Thank for all your time a59303
I think I have discovered the issue… and it’s a bit of a Doh moment for me.
So I set the sim to stop at a certain frame say 30 thinking that from that point the smoke would not evolve and hold its shape, indeed that seemed to be the case in the viewport.
However all my test renders where outside of the 30 frames used for the sim so…no sim no smoke.
Looks like ill have to find an alternative way to freeze the smoke.

Thanks again a59303

Yeah, I can’t really think of a solution there. If you just want the shape you could continue the sim and animate/turn off the forces/wind. Your welcome.

1 Like

That’s a thought, I’ll give it a try :slight_smile: