manual remesh .. the new mesh isnt visible

I’m trying to manually remesh an object by adding another mesh on top of it and snapping to surfaces.
The original mesh is a bit complex, so i rather turn this one manually to quads.
The problem i have is, the original mesh shows often over my new generated mesh so i cannt see it that good.
I need some way to make the original mesh more transparant how should i do this ?

With the new mesh that you are creating selected in its object properties check the ‘x ray’ option, and then in the N panel check the’ hidden wire’ option too. This seems to work the best for me although it’s not quite perfected yet in terms of hiding the other side but at least its not quite as overlapped as with just x ray.

Solved it, one has to enable Xray in object panel.