Map input xyz offsets?

from the wiki:

Options

Map Input Panel

[ofsX, ofsY,ofsZ - Offset The texture co-ordinates can be translated by an offset. Enlarging of the Ofs moves the texture towards the top left.
Does that mean the top left of the object? from the camera’s point of view? or?

Ive moved this stupid coffee stain projection all over the place and i cant see it. but if I put repeat on I can, only too many

Thanks, I’m a little frustrated right now.

In F7, Draw tab, DrawExtra, turn on Axis to see which way textures are offset.

%<

Thanks Fligh, but I still dont get it…
It matches the hand axis lines. I had a 3d chess set once, wish I had it now to figure the coordinates.

on the x, y plane, is 0,0 in the center or at a corner?

I think it must start from a corner

Ok, so like an hour later Ive decided I dont want no stinken coffee stain on my table! ROFL.

It’s the Center by default. In F7, same place turn on TexSpace then, in Object mode, hit T and you can scale and grab TexSpace. On a Plane it will be 2D, on anything else it’ll be 3D and relative to the 3 coordinates of the texture (actually the texture display is relative to TexSpace).

%<

OH Fligh, thank you. I forgot about the textures space thing. Never used it except to play with for second.

I will try that. I think the texture is just white and blends in too much with my other textures, even though its now on top.

oK, I played with that and scaled it down, but since it is 2d and looks 3d (a cube and yes the table is just a plane) I wasnt sure about shrinking it on the z axis, but I did. And I think it is on the table and not floating in the air, but its small.

Anyway, I still cant see it. I will have to play with this again, with something I know I can see, like a red dot or something. I dont know.

Anyway, thanks for helping.

a lot of times when I have trouble i switch everything off to get back to a known state, and then switch that one thing on and see what it is doing, and then start turning other stuff back on so my brain can keep it straight.

OK. So I couldnt give up and decided to just delete the stain and add it back in. The odd thing is, that when I deleted it, the texspace frame stayed there.

And when I added it back in the frame only got a little bigger and lifted up a bit. Its a 3d cube. and as you can see in the pic, I now can see it on the table.

Except, I can see the whole picture, instead of just the stain. Make sense?

So thanks for sticking with me. Now i just have to figure out how to make the darker part of the pic go away!

Attachments


God, its supposed to show like that! Tuts! It was just showing the stain when it was 3 levels down. So I guess in this tut you have to read two or three pages ahead, just incase.

But the tut now says this:

The Mix blend mode has mixed both the Black background, of the image, as well as the stain mark itself. We need to get rid of the black background. Once again Blender has the ability to do this.
[QUOTESwitch to the Texture Button F6 and in the Image tab select CalcAlpha and UseAlpha. This will make the black area of the image transparent. [/quote]

Then it says this right afterwards:

NOTE: : Alpha, in materials, is quite complex. Here we are not using any alpha to make the material itself transparent. However, there are examples in later files that use material alpha.

So can some body please explain that? Is it using the alpha or not.

Thanks very much.

It all still confounds me a little but at a guess I’d say what it means is that an image can be saved with an Alpha Channel (from Photoshop or Gimp or whetever) and you can tell Blender to recognise (use) this alpha channel. However, in the example you give above, you’ve told Blender to CalcAlpha which basically means there is no Alpha channel embedded in the image but Blender will try to make (calculate) one based on the colours.

As for placing your coffee stain, I would have thought it would be better to use an empty to position it.

what Andy said and then map the location of that image to OBJect and type the name of the empty in the OB: field; this is a decal and you’ve seen/done those before, yeah?

LOL, No, I havent. But I understand what you are saying because I helped someone else with a challenge of object/empty thingy in the textures.

I didnt know why it was there, but understood a little bit. You know, a feeling, hunch, glimmer? giggling.

It was fun. And explains why you would use one over the other. You can find it and drag it around easier!

And Now I think I understand the ‘yes we are using alpha and no we arent using alpha’ from the tut above.

The image doesnt really have any alpha channel. But blender options allow you to pretend you do.
Its using the image as a mask. Does it have to be a black & white image?

Thanks for help.