Mapping keyboard shortcut to select mode (vertex/edge/face), on laptop

Various answers don’t give an answer I’ve been able to use.

With numpad emulation on (blender 2.9) if I map shift + numpad 1, shift + numpad 2, and shift + numpad 3 to the select mode, it acts like Ctrl + mouse click, on the icon. In other words, to switch between vertex and face, I have select face then deselect vertex, otherwise they are both selected. Is there a way to change this so each is exclusive?

Find your mappings in the keymap editor and forcibly disable the Extend and Expand checkboxes in them (if they’re grayed out, click on them until they’re not greyed out and turned off).

1 Like

That works. Thanks!