"Mark Seam" Not Showing Seam!

Hi All. I’m using Blender 2.40 to make models for our open-source flight sim and I just ran into a strange problem. While unwrapping UV’s for the texture, I noticed I could not make a seam between two verticies on the missile cylinder. The strange part is that it has worked on prior missile models. Here is what is happening:

I first select the vert on the top of the cylinder. (you can see the seam I already made around the circumference)

http://www.phoeinxosfs.org/honcho/AA-7B-Help1.jpg

Next, I select the vert on the bottom of the cylinder. The yellow line tells me I have the two verts lined up correctly.

http://www.phoeinxosfs.org/honcho/AA-7B-Help2.jpg

I select edge specials to mark the seam,

http://www.phoeinxosfs.org/honcho/AA-7B-Help3.jpg

But when I go to the UV face select mode, there is no seam! The other seam I made is visible at the top of the missile.

http://www.phoeinxosfs.org/honcho/AA-7B-Help4.jpg

I thought maybe blender wasn’t displaying the seam, but it was still there. So, I selected the cylinder faces and unwrapped. Instead of getting the nice, even rectangle I expected, I got the smushed result that indicates no seam.

http://www.phoeinxosfs.org/honcho/AA-7B-Help5.jpg

Does anyone know what’s going on? Any assistance would be greatly appreciated!

Your pictures dont show for me , maybe try selecting in edge mode rather then vert mode just incase those two verts are not connected.

Sorry, I don’t seem to be able to enable html code, so no pics. I’ll try it in edge mode and see what happens. Thanks!

Still no Joy. Maybe I should delete the edges and re-make the cylinder?