Masking on Sculpt Mode

Hi folks.How are u?

I’m having an issue with the sculpt mode in Blender.
I want to be able to do stroke masks.
What I mean by this is: just by holding down a key, say CTRL, it would activate mask brush and let u do masking by executing clicks on a part of the mesh, but when CTRL is released the sculpt mode goes back to the previously brush selected so the mask system would be faster and more dynamic to use (similar to Zbrush).
I’ve seen it can be done with smooth for example which comes by default with the sculpt.brush_stroke operator but it seems like it doesn’t allow mask so I couldn’t find a solution yet.
Any help would be appreciated.

Cheers :slight_smile:

The hotkey to enable the mask brush is “M” paint the mask you want then if you press “M” again it will go back to the sculpt brush.