Match object shape with out breaking its size and orientation

I would like active object on curve to fill space with even spacing (360 degrees) but what I end up is

Make sure your curve and objects origin point is at the same place. See attached file.
Cuves.blend (759.5 KB)

1 Like

Welcome!

Remember, to make Curve modifier work in a predictable manner you need to meet certain conditions: both objects should be in the same Location - their Origin points should be in the same place AND they should have matching Scale and Rotation. Best to Apply Scale/Rotaion for both objects if it’s possible.

Additionally, when you get your array to curve properly it might not align the elements perfectly at the end of the Curve - in a cyclic curve the array can overlap or leave a gap. There is a handy Stretch and Bound Clamp options in Curve Data Property that will adjust the curved array to the length.

1 Like

Thanks for hints but still not doing great. Updated Curves.blend with my problem.
Cuves.blend (898.1 KB)

@GrimZA could You take a look?

Select the array object and the curve in object mode, press ‘Ctrl+A’ and select apply ‘Rotation and Scale’.
Next select the curve, go to object data properties and disable ‘curve deform radius’.

Sorry for the late reply, i am not on the site daily.

No problem thank You for participation.
There are two more problems to address

  • Glitch at 8 hour (one object to much or calculation is wrong)
  • Why my shape has been rotated and how to over come it?

Glitch at 8 hour (one object to much or calculation is wrong)

There isn’t enough space on the curve for the selected offset, you can either change the offset or scale the curve up or down.

Why my shape has been rotated and how to over come it?

The curve doesn’t care where the object is, it only knows that the X direction of the object is up. You can change the rotation of the object by selecting it, switching to edit mode, selecting everything making up the object and then rotating it.

@GrimZA Thanks made it!

1 Like