Matching maya's grid

Hey guys want to keep it short.

wondering if there was a way to match blenders “units” to maya’s dimensions? I cant seem to get it right is there some complicated math I need to do or is there a single button I can hit. I’ve tried all of the standard stuff like messing with the presets in blender. let me know if that doesn’t make sense

Joshua Cotter

Can you post some screenshots to describe what you are looking for?

thanks and sure.

maya’s dimensions and viewport shot

exported to blender which looks like this

as you can see the blender grid doesnt line up to the grid in maya

they are both set to inches

What format are you exporting/importing?

The scale is mostly controlled by the individual importer.

hey im using .obj let me try .fbx

still not lining up with fbx either

How big are those objects in blender?

I have found a few different cases where the units don’t work right, especially when importing. I leave everything set to unitless dimensions, and then just imagine they are inches.

ah exporting as an fbx seems to have workedwondering if its possible to match the perspective veiw grid floor to what I see in orthographic view?



it seems my subdivisions are greyed out


the objects are 2 square inches

When you have imperial units set, it disables subdivisions.

This is a good example of why I don’t use the units typically. The subdivisions only show up in ortho mode.

If you set everything to 1 blender unit = 1 inch and ignore the units setting, you can at least have a more consistent user experience.

Alternately, you could move up to blender 2.8 which overhauled the units settings and made them more consistent.

PS, to each his own, but that color theme is brutal.

lol yeah not really easy on the eye’s for wires.

thanks a bunch! this was super helpful and constructive :slight_smile:

1 Like