Matching Two Layer Lighting


I have my Bottle on one layer, background on another and my “table” on another. All three layers have different lightings. But the lighting for the bottom outside edges of my bottle does not match the lighting of the table. Its just too bright. I tried using an RGB curve and while it fixed the outside edges it REALLY darkened the rest of the bottle. Is there a way to darken the edges without affecting the inside?

Here is my file.Blender Cola.blend (1010 KB)

Well the contents of the bottle is black and tends not to reflect much light. The glass of a real bottle reflects light in a shiny manner, I don’t see much in the way of reflections in this render. They are a bit to subtle.

Real photographers take ages to light bottle and reflective surfaces correctly so don’t be to upset if you don’t get it right the first time. I think that it looks great.

Try retargeting the black point using a curve node. That is alter the Black Level value to match something like the background blacks. But you may have to push your lights in closer to get more light wrap on the sides.

Don’t have time to check the blend file right now but the quick answer to your question is, yes, you could change the luminosity of any part using a mask to control which areas are affected. This will probably not help very much because a realistic result would require the liquid in the container to be semi-transparent. Finally, not only matching blacks and whites is required but also the final composite should be color-graded to be believable.

@ 3pointEdit - Thanks man. I tried lighting it up to get some secularity but instead of reflecting the light in a small sharp way it lights up the whole thing and it gets a little ugly blown out results (that is when I have shadeless unchecked). I’ll try adding a curve node and readjusting the lights and see what happens. Should I try to have shadeless turned on or off to help?

@ blendercomp - I tried making a mask in the compositor and I did get somewhat decent results in color, the mask came out very “digital” so it’s not very smooth.