Material Indices in Cycles render missing


I have a funny problem when rendering with CUDA and Cycles in Windows 7. I have a blend which works very well on my main Windows 7 box with CUDA, as well as with CPU on Linux and OSX (ATI/old NVIDIA, so no CUDA).

But, as this is a animation, I use all my computers to render different frames, and this works nicely (though I would love a centrally managed system like for the default render, but that’s besides the point), for all of them except one - my second Windows 7 box.

It has a GXT 260, and CUDA GPU rendering works fine normally. However, whenever I open the same blend file as on all the other systems (Dropbox shared), the final render has no material indices - they are all blank. As I have my lights on a separate material index for blurring etc. in the final composite, this means I can’t really use the render. When doing CPU rendering on the same box, this does not happen however.

My question thus becomes: why on earth, would the material indices be missing on one Windows 7 box, and not on the other? The only thing I can think of is that the GPU on the box with the missing render layers has less RAM than the one where it works. But it does render the scene completely, it is only the compositing that fails due to the missing material indices, and that doesn’t sound like a RAM problem, or does it?

Any thoughts and wild theories are very welcome indeed :slight_smile:

Hi, I work with the GTX 260 for a long time but change it because Compute Capability 1.3 has some limitations in cycles.
Render layers don´t work is one of them.
I don´t understand “separate material index” but it is may the GTX 260 limits here.
Change the GFX cards between you win 7 boxes to verify 100%.
All newer nvidia cards use the same driver so it is not a problem.

Cheers, mib.

Hi mib - sorry for my late response. I think you hit the nail on the head there with the GTX 260. I did some testing with render layers (which is what I need) and your diagnosis seems correct. So I guess, the only option is a newer GPU for the box, as the CPU is too slow to be practical. You saved me a lot of time here mib, thanks a lot!