Material Mode Viewport Transparecy?

OK, time to pick your brains people! One of the things that drives me up the wall is how viewport transparency, and OpenGL rendering with transparency, is mangled when using the cycles renderer. I know that the big viewport fix is in the works for 2.8. But I also know that no more viewport work is being done for 2.7X. So it’s six or seven months away, at least.

First I should probably ask. Does everyone else have the issue where viewport transparency only works in material mode, and then the transparency is dithered with white? If not, show me the secret sauce that makes it work as it should.

Otherwise… Here’s my fix… I just need help in making it work a little more seamlessly. I figured out that the transparency isn’t just dithered with white; It’s dithered with the color of the transparency shader. So I made a node group that contains a value node that will override the transparency shader color with a custom color or image map. By putting the value node inside the group, you can just tab into the group and change the override value to toggle all instances of the group. That way it can be used all over the place, and one change changes them all.

My question… How do I link that value node to something outside the node editor, like a custom property of the scene, so I can stick it on a toggle in the N panel? Here’s my file, fix it…


VP_Transparency.blend (655 KB)


Here is a Screenshot of Your Blend file.

Seems like it works as it should…?

Render ok - Viewport - ok…Transparent only show in Materiale Mode…Not solid and Texture.

Sorry can’t help with Your Node…I disconnected it.


Your screenshot proves it doesn’t work as it should. If your eyes think the colors in the viewport are faithful to the image or rendered version, then that’s good. But for me it’s not. White eyelashes and hair are fine, if your hair and eyelashes are white. But thank you for showing that it’s not just my system that looks rotten.

It is curious though how you can’t see the difference…

No I do not think the color looks the same…:slight_smile:

I just get a little confused You picture and Your Blend…:slight_smile:

Here is another picture…Did this looks right…?


Is this the image that confuses you?

Here’s the raw image.

Can you tell me why the material viewport turns it white? And, is that working like it should?

Yet the fact remains, that isn’t the problem I’m having. The problem I was having is getting a driver set on the mix factor, from outside of the node editor. According to posts I found on stackexchange it’s a depsgraph issue. And though I could get a driver to change the value, it didn’t force an update of the shader. The only reliable method I found is setting the mix factor directly with python and that’s what I’m doing.

I think if you set a material transp and are in mat mode it wont shown in viewport only in solid mode

it is a know bug and should be corrected soon I hope
or only in 2.8

happy cl

Yea…It that picture I get cunfused at.

Sorry can’t say why it’s show white…Have You tried with some other .png’s…To check it’s not the .png there something wrong with…?

Don’t know how to fix it…:frowning:

Ricky…It’s the other way around…Transparent only show in Materiale view…:slight_smile:


I don’t get it. If I plug the image color directly into the transparency color it renders fine and viewport is fine.

sorry was not talking about image transp
more about material in cycles

have not tested images png in a while

happy cl


It looks right in the viewport and it render…But if You plug Color into Transparent Node…It will render black instead of transparent.