material nodes - texture [map to] issue

Can anyone tell me how I can change the orientation of textures in the material node editor? all i get at the moment is the flat option, rather than a sphere, cube etc.

also, is there a way to overlay an alpha mapped texture on a material with existing ray transparency? I’m getting very odd results at the moment…

Dan