Material override in RenderLayer and "Traceable"

I’m create material with option “Shadows only” enabled and “Traceable” disabled

And than i’m trying render images using two ways:

  1. Specify in “Material” field of RenderLayer that material
  2. Manually change materials of all objects to that material

And I get as render result different images… In first case blender ignore “Traceable” option of overriden material…

How can i avoid this difference?