Material Preview Blur

Dear all,

Could anyone suggest what I’ve done to my .blend file that would cause the material preview to go all blurry? It’s only this .blend file, and does it in both 2.90 and 2.91. I’ve clearly hit a wrong button somewhere and now can’t figure it out. Solid view and Render Preview are both fine.



Maybe you’ve adjusted the Filter Size in render settings under Film? You can right click it and Reset to Default Value.

Thanks, I’ll check it out.

No. It wasn’t that. It’s not a huge problem as most of the objects were appended, so I rebuilt it and this problem did not reappear. I’m just really curious in case it happens again. I can link the file if anyone’s interested.

Please do :slight_smile:

File is here -

I’ve tried both 2.90 and 2.91, and they both do it, but only with this file.

Sorry I thought it was the blur value under viewport options. That is not it either. I thought it was related since the blur changes (dissapears) as you change the value but it returns when you let go. Even when you set blur to zero. The only thing the blur slider does under viewport options is to blur the environment texture.

I tried a few other things but with no results to show for it. Sorry, I have no idea what is going on here. :slightly_frowning_face:

Switch the render engine to Eevee and reduce the Filter Size under Film there :slight_smile:


Stan_Pancakes - Good Call!

No idea how I did that given that I never use EEVEE, but good to know how to fix if it happens again.

Thanks all!