Material/shader not working on my mesh/object

Hello all,

I purchased a model of a guitar from and I’m trying to apply my own custom shaders to it, and it’s working on some parts, but not others, and I can’t figure out why. I’ve been searching for the answer for 2 hours, and I can’t find it. I’ve updated to the latest version of blender (2.82) in case it was a bug, and nothing. You can see what I’m talking about in the attached link. I tried making a shader from scratch, and nothing appears. I tried making a shader using extreme PBR add-on, and nothing appears. I tried eevee, and cycles render, and nothing appears. It’s VERY frustrating, and I’m betting it’s a box that is check marked or something causing the problem.

What am I doing wrong??? Much appreciation for anybody who helps me solve this problem!

it seems you want to use the materials from the extreme addon.i dont have this addon,but i think the key is to use it as it should.

maybe this video can help you, or open a topic for the extrem addon questions, if it doesent work for you.

would like to see the complete ibanez render :sunglasses:

or came the ibanez model with own textures/materials?if the model dont have a blend file with materials,i think you have to setup your own PBR material and load the textures by hand,and assign it for each object.

Without the Blender file, it will be a guessing game, I think. Anyway, I will stay at 2.81a, especially with a lot of addons.

Thank you so much! Unfortunately, that is not the issue. As you can see in the beginning of the video, I pull up a brand new shader (Extreme PBR is not applied at all), and I attempt to change the color to red. Unfortunately it doesn’t work. It’s no specific to Extreme PBR, as NO shaders will apply to it.

The file that it came with did come with some image files, but I wanted to customize it, and I chopped the model in pieces in order to apply my own materials to each section. For some materials it works, and others it doesn’t, and I still have no idea why.

I can upload the blend file if you think it would be helpful.

Unfortunately the problem existed in 2.81a as well, so that isn’t the issue. I updated to 2.82 in the hopes that it would solve my problem, but unfortunately it didn’t.

Does it work on the default cube? Does the piece of guitar still have uv mapping? But never mind you can let out any unnecessary stuff if the file is too big

Here is a link to the file. It was too big to upload here unfortunately.

  • link deleted -

Yes, it works on the default cube. I’m unaware of any UV mapping anywhere as it’s something I avoid if I can. Perhaps that is the reason? I don’t need to do any UV mapping to apply a material to the default cube though.

check your material slots:

I added the magenta material to diagnose what was going on.

Make sure that you are adding your material to a useful material slot.

1 Like

exactly what @SterlingRoth says if you delete the marked slots everything should work again. maybe that happened while trying things out.

1 Like

THANK YOU!! @SterlingRoth AND @MarioPeper !!

IT WORKS!! Oh man, I knew it was gonna be something stupid and simple like that!! That’s what I get for being a noob.

Thank you!!!

1 Like