Material Transparency Question

I have a lantern mesh that has an image “mapped to” “alpha” in the “materials buttons” so that I can create a custom-shaped window in the lantern. I have “ZTransp”" on and “DVar” set to zero. The lantern looks great. Now, when I set a Lamp style lamp inside, I notice no light gets through the clear window. Is there any way to make the light come through and maybe even cast some shapèd light spots?

I THINK that you should turn off the “traceable” option, on your material settings, in the “Render Pipeline” buttons just below the drop menu you use to select materials.

So is it all or nothing? I cant get shadows from the shape of the alpha transparency?

Turn on TraShadow (Shading Context>Material Subcontext>Shaders Panel) for all the objects the alpha-mapped object will be casting shadows on.