Material with good-looking emit test

You know how turning the emit value in the material settings removes all shading? I just poked around in the compositor trying to bring back some of the shapes from the shading back into the render:

http://dl.dropbox.com/u/14243021/Artwork/2011-01-05%20Glow%20test/render1_600width.jpg

Here is the raw renderlayer, notice the distinctive flat shading of the water:
http://dl.dropbox.com/u/14243021/Artwork/2011-01-05%20Glow%20test/flat.jpg

In the compositor: Multiply scene node with masked clay renderlayer.

Here’s a render with that technique applied:
http://dl.dropbox.com/u/14243021/Artwork/2011-01-05%20Glow%20test/blue_glow_small.jpg

cool! nice b-tron shader :slight_smile:

Very good idea!

i’m vaguely familiar with the id mask node; how did you use it in your compositing?

Great looking emission material.

Looking back at the scene I saw that I only used the IndexOB for the glow effect, to mask out I rather placed the object on another layer name “clay”, take a look:

http://dl.dropbox.com/u/14243021/Artwork/2011-01-05%20Glow%20test/node_setup.png

The clay material used in the renderlayer “clay” is just a simple default nospec material. The clay render is a little blue because of the lighting from the blue indirect light, so I desaturated the image before multiplying. It actually looked way better and emissive that way compared to disabling the indirect pass in the Passes settings.

ah ok; thank you for the compositing screenshot. i’ve always wondered why turning up emit makes objects so flat and shadeless. i was inspired to test this out, and i actually just tried using an AO pass excluded from the combined pass and multiplied the image by that. it seemed to work pretty well, but i’ll try this too.

i tried messing with the indexOB pass but couldn’t quite figure out how to get rid of some aliasing all around the edge of the mask; i’m missing something here but i dunno what. in that screenshot, are you inputting the indexOB pass into the alpha socket on the composite node?

Sorry, I missed your reply. I actually didn’t use the indexOB, but instead isolated the fluid on another renderlayer with a forced clay material. Here’s the blend, check it out!: http://dl.dropbox.com/u/14243021/Files/packed_glow_water_artorp.blend

Generally speaking, turning on FSA should get rid of most aliasing issues concering the compositor, but sometimes the issues arises from something else, like non-premultiplied alpha maps.

I like the glow effect you got with the second render with the monkey. Do you still have the blend file for that? How do you put one object on 2 render layers?

Looking back at the files, I realized I actually used two different techniques for the images… don’t know how I forgot that, well well…

The 2nd render uses some material node balancing to separate the emit value and the actual indirect lighting effect from therein. Here’s the blend file:

http://dl.dropbox.com/u/14243021/Files/scene_glowingy_artorp.blend

Now take a look at this picture:

It’s the material applied to the glowing objects. I made it this way:

  • Set up a material with appropriate color and emit value, so that the environments are well lit. Don’t worry about the actual object itself just yet.
  • Enable nodes for your material. Pull up the node editor.
  • Duplicate the material input. Make it single user by clicking on the number next to the material name. Now drag it’s output socket to the input socket of the output node. It should look identical to the screenschot attached (minus the normal trick off course).
  • Lower the emit value of the duplicated material.

The way this works as I understand it is that the approximate indirect lighting now associate the first material with the light source. It’s emit value will now affect the lights that spread to the other objects. The other material, however, will only affect the object in question. You can crank the emit value up and it won’t affect the indirect lighting, and you an turn in off, making it render completely non-glowingly and with the shading completely visible. Or you could mix in some fancy normal gradient like I did.

I don’t really like this approach that much, since it gives no good indication of predictability, and could quickly change behavior in future versions of blender. But for now, it works.

While this hack does not utilize render layers (and the first technique depend on them) setting up render layers is practicable.
With an object selected, press ‘M’. This will open the all-so-familiar object layer menu. To move an object to multiple layers, hold shift while selecting layers. Then, when setting up the render layers, the object will reside on more than one object layer in which case it’s just a matter of selecting the right object layers for each render layer. :slight_smile:

Thank you . I like to study this. The lighting looks very good.