Material with textures and metallic look

Hi,

i am farly new to Blender 2.5 abd having some trouble with the materials.

i have exported some EVE Online models for rendering some pics.
here is a short vid how it should look like

http://www.youtube.com/watch?v=itqa0tjjDWI&feature=autoplay&list=ULwK5lIlhjx-g&index=1&playnext=1

Edit: sry i linked the wrong URL and the system wont let me change it. plz watch the other vid i posted on YT.

and how it actually looks like:

http://www.youtube.com/watch?v=q_WyoI6ZcW8&feature=mfu_in_order&list=UL

i also exported the textures and the masks for spec, lights and the glossy glass/metal parts on the ship.

now my question: how can i set up my material to look like ingame?
i tried wo make an additional material and assign it to the faces but they dont fit to the diffuse map. i tried to set the influenze to mirror respectivly to ray mirror but it didnt changed anything in the rendered pic. i googled for metal material and found somethink with gold but the author used some pic and mapped them to reflection and i havent such a pic.

anyone how could help me?

LoF

You have to add the maps as texture channels of type ‘image’, and set the map input to UV, and the influence to whatever they were intended for ( refl, spec, etc ). You should not need multiple materials. You can do it with multiple materials using the node editor, but I don’t know if that works in the game engine.

i did so but it doesnt work. if i tick the mirror check box in the influence tab nothing happens.

So you have the 3D model right? Before you can mess with texture like that you will need UV map of it. Do you have the UV map?

In the image mapping coordinates you need to set it to reflect. This doesn’t actually use raytracing, it just fakes a reflection.

i have the model and the textures from the eve client. i had to mirror them in ps vertically to fit to the model in blender. then i set the mapping to UV for diffuse and so on. the textures are set probably to the mesh as you can see from the pics. where the reflection should be there are white spots on the masks texture. the last pic is how it looks like. i can see the map reflecting but this is wrong. i dont know if the settings on influence are right.




What you have here is the Specular map. In your screen shot you have Specular color activated, as it should. You need to activate the Intensity, and Hardness as well. Additionally, in the main materials, turn all overall specular setting to zero. Other wise you are going to end up with two independent specular settings and Blender don’t know what to do with that!

i used this image as spec till now so what do you think could this be used for? some kind of surface map for “dirt and rust” ?


try mapping it to reflectivity. that would be my guess.