Material won't assign to selected area.

Hey guys… I got an issue that’s quite hard to understand.

Alright so for some reason when I assign my skin material (Green Colored Material) to my characters eye lid it just totally ignores it. Well it ignores it in texture mode, but it doesn’t ignore it solid view mode.

I don’t get it. Does my Eye lid mesh has something like “Ignore Textured Material” I just can’t find a solution. I think it has something to do with vertex’s but I don’t Know.

Well anyways here’s what I mean.


My other Mesh’s apply the skin just fine but the eyelid is all like… “Nope”
This is also how it is viewed in Texture mode.


In Solid mode it looks just fine.


That’s how it is in Rendered view.

Yes it’s totally normal here too but this isn’t really my main goal.

Do you have a texture in your ‘Skin’ material? have you changed the display properties of your object?..

Thanks for the reply dude.

No my Skin Material doesn’t have a texture for it. But I’m using the same material for my characters body and Eyelid, so I’d expect both of them to be treated the same. And about the display settings, I never really seen that before. Maybe it could help. But how do I open it?

the display settings are here:

of course it would be faster for us to help you if you could show us your blend file… Without that, we can only guess! :confused:

Oh. Mhm, I checked that and the Maximum draw type is also Texture, as my other material.

Thanks for wanting to check this out.

Much respect for giving me a hand with this thing.

http://www.pasteall.org/blend/30916

My main goal is trying to import this bad boy onto Unity.

Here’s how It look like when I Import it into Unity.


Lol looks like someone sucker punched his left eye, and sent his right one to another dimension.

Fixed it. Guess it really did have sumthing to do with my vertex.

In my Eyelids I had sumthing called Col, in my Vertex Colors. I have no idea what that was but I got rid of it ad I can see my texture now.

Now i’ll test it in Unity and see how it goes.