Materials are either all white or black in eevee? How do I fix?

All are within acceptable ranges.

The bar is complete, the shaders are compiled, but it seems to have goofed. Yeah, the material textures will show up in solid view.

GTX 980ti, i7 5820k, 16GB DDR4

I found the solution here…

“I tried reopening the file multiple times without luck, but what did fix it was opening a different file. I spent a moment panning around that scene, switched render views, then re-opened the file with the issue.”
~ mdcrtv

So it seems to be a bug with Blender… something broke when the shaders were initially compiling and messing around in a new scene seems to clear whatever the issue was up.

1 Like


Load up the broken scene and save out as a new file. Delete everything in it and add a suzanne or something. Purge out anything unused (materials, textures etc). If still broken, attach file here so we could have a look at it. Possibly submit it in a bug report.

I have had project files where camera views are broken, but I can’t explain what got them into that state. Devs were quickly able to identify what was going on and I believe that particular bug was fixed. Yours kinda smell similar.

I noticed the same thing in two different files (today and a few weeks earlier). I discovered that I could update it to render correctly when toggling the visibility of some of the objects, in this case being the camera collection for some reason. I don’t completely get why it happens and doing such a thing fixes it.



Note: I am on Blender 2.81, Windows 10, with a graphics card GTX 1060 6GB

Could it be a GPU driver issue? Or is it only on a given build? I have 2.80, 2.81 & 2.82 on my system. Maybe throw them on and see if it’s the same across each build?

Well, whatever it is, it very clearly needs to be a bug report.

I did an extra bit of testing to see what the issue was. It seems to be related to particle systems. Back in my example, I toggled the visibility of the Camera collection, which also contained the particle system for the scattered rocks on the ground. Before that, I also had the same black and white issue with a scene that used grass in a particle system.
Toggling the visiblity of the object with the particle system fixes it for me.

I have created a bug report.

Hi, my solution for the same problem in blender 2.81.16 and 2.81.16 under Ubuntu with nvidia 1060 with proprietary driver(stable) and the inside processor i7-9700K
the problem was under eevee and material preview:
i go to preferences -> systems in CUDA and i deselect all graphics then the problem disappear now i reactivate and the problem is gone.

No reboot and other.

Hi all, it seems to be a Eevee shader issue on some scenes. Anyway there is a simple and fast solution that works for me: select just an object and toggle local view, then select material preview and the object should be shown correctly. Then turn off local view and the issue should be gone. I hope this helps!

1 Like

I’m having the same issue, and it happened after switching from cycles to eevee.
By the way, the bug report was closed soon after being opened, it was never looked into.

Although I haven’t seen a case yet for 2.82 onwards so I would assume it is fixed there. Were you using 2.81 or before?

I am in Blender 2.82 and still have this issue, and this fixed it.

I’m using a large scene with lots of objects. Switching between cycles and eevee probably prevented shaders to recompile, or something broke along the road.

yeah, this works on 2.82a, but damn, wasn’t it frustrating to find solution for this bug :smiley:

This happens to me and the way I fix it is just turn off/uncheck some collections until it fixes itself then turn em back on. This usually happens for me when I got multiple objects on the scene.

That’s interesting. I never had any issue with 2.82, only 2.81 and earlier.

This problem still exist, I am using 2.82.7

There are 2 fixes I found out that work. Like @MJ_Vilches said, turn on/off some collections until the textures are back again. Another one that works is to start Blender and then open your scene via ‘open’. Directly opening a .blend file from your explorer will leave me with all the materials white.

Is there a way to forward this bug again ? I can’t share my file but there must be others with the same problem ?