Materials are either all white or black in eevee? How do I fix?

Load up the broken scene and save out as a new file. Delete everything in it and add a suzanne or something. Purge out anything unused (materials, textures etc). If still broken, attach file here so we could have a look at it. Possibly submit it in a bug report.

I have had project files where camera views are broken, but I can’t explain what got them into that state. Devs were quickly able to identify what was going on and I believe that particular bug was fixed. Yours kinda smell similar.

I noticed the same thing in two different files (today and a few weeks earlier). I discovered that I could update it to render correctly when toggling the visibility of some of the objects, in this case being the camera collection for some reason. I don’t completely get why it happens and doing such a thing fixes it.

Before:

After:

Note: I am on Blender 2.81, Windows 10, with a graphics card GTX 1060 6GB

Could it be a GPU driver issue? Or is it only on a given build? I have 2.80, 2.81 & 2.82 on my system. Maybe throw them on and see if it’s the same across each build?

Well, whatever it is, it very clearly needs to be a bug report.

I did an extra bit of testing to see what the issue was. It seems to be related to particle systems. Back in my example, I toggled the visibility of the Camera collection, which also contained the particle system for the scattered rocks on the ground. Before that, I also had the same black and white issue with a scene that used grass in a particle system.
Toggling the visiblity of the object with the particle system fixes it for me.

I have created a bug report.
https://developer.blender.org/T73119

Hi, my solution for the same problem in blender 2.81.16 and 2.81.16 under Ubuntu with nvidia 1060 with proprietary driver(stable) and the inside processor i7-9700K
the problem was under eevee and material preview:
i go to preferences -> systems in CUDA and i deselect all graphics then the problem disappear now i reactivate and the problem is gone.

No reboot and other.

Hi all, it seems to be a Eevee shader issue on some scenes. Anyway there is a simple and fast solution that works for me: select just an object and toggle local view, then select material preview and the object should be shown correctly. Then turn off local view and the issue should be gone. I hope this helps!

1 Like

I’m having the same issue, and it happened after switching from cycles to eevee.
By the way, the bug report was closed soon after being opened, it was never looked into.

Although I haven’t seen a case yet for 2.82 onwards so I would assume it is fixed there. Were you using 2.81 or before?

I am in Blender 2.82 and still have this issue, and this fixed it.

2.82
I’m using a large scene with lots of objects. Switching between cycles and eevee probably prevented shaders to recompile, or something broke along the road.

yeah, this works on 2.82a, but damn, wasn’t it frustrating to find solution for this bug :smiley:

This happens to me and the way I fix it is just turn off/uncheck some collections until it fixes itself then turn em back on. This usually happens for me when I got multiple objects on the scene.

That’s interesting. I never had any issue with 2.82, only 2.81 and earlier.

This problem still exist, I am using 2.82.7

There are 2 fixes I found out that work. Like @MJ_Vilches said, turn on/off some collections until the textures are back again. Another one that works is to start Blender and then open your scene via ‘open’. Directly opening a .blend file from your explorer will leave me with all the materials white.

Is there a way to forward this bug again ? I can’t share my file but there must be others with the same problem ?

This problem still exists in current 2.9 version :slight_smile: But I’ve noticed that Clément has noticed it already and, as such, I expect it eventually appears mentioned here as fixed.

Okay i recorded several videos of this problem in action.

I’m using Blender 2.83.2 with my own .blend file.

The fully packed .blend file is here:
https://drive.google.com/file/d/1ts0PkV3hEORE1YQXl-BDtupFgvlFVbq_/view?usp=sharing

I’m including it so people can debug it if possible.

I have a series of three youtube videos capturing what occurred. Note, this .blend file takes 30 seconds to a minute to load on my machine (64GBs, Intel Core7, Nvidia Quadro 4000, Win10)

go here to see the bug in action. Each video has some description as to what you are seeing:

Part 1: https://www.youtube.com/watch?v=8560WsF42Lo
Part 2 and 3 are right after this one…

Basically the summary is the following:
0) the file is 2GB in size so its takes a minute to load everything

  1. the .blend file has been saved with Eevee as the renderer
  2. go into material mode and everything is white
  3. turn off most (or all) of the collections
  4. IMPORTANT: Turn off the collection named “New Lawn” as this has a particle system on it
  5. start turning collections back on in the viewport and materials sometimes appear as normal
    but most of the time come back white
  6. if step #5 resulted in more ‘white out’, then switch renderer to Cycles
    • then turn off everything and turn back on and you will see materials back

At this point, if you render in Cycles (render in the viewport, not F12), things work

If you go back to Eevee and go into viewport render mode, immediate crash.

This has to be a bug… What else can I do to help verify it?

thanks

forgot to mention… the particle system on “New Lawn” collection was created by GrasWald3D Pro.
So i guess unless you have Graswald3d on your blender you won’t be able to render it/see it.

in that case, perhaps just create a simple plain with some particles on it to stand in its place?

I’m now seeing this in other projects… its unclear what is triggering it. I thought perhaps it was due to Graswald or some other subtle problem with the particle systems, etc. However, i have other projects that use the same assets and don’t get the ‘white object of death’ effect.

Its almost like Blender isn’t compiling the shaders and just quits. I’m upgraded to Blender 2.83.4 and see the same issues.

would love to hear any thoughts from anyone