Materials are either all white or black in eevee? How do I fix?

This happens to me and the way I fix it is just turn off/uncheck some collections until it fixes itself then turn em back on. This usually happens for me when I got multiple objects on the scene.

That’s interesting. I never had any issue with 2.82, only 2.81 and earlier.

This problem still exist, I am using 2.82.7

There are 2 fixes I found out that work. Like @MJ_Vilches said, turn on/off some collections until the textures are back again. Another one that works is to start Blender and then open your scene via ‘open’. Directly opening a .blend file from your explorer will leave me with all the materials white.

Is there a way to forward this bug again ? I can’t share my file but there must be others with the same problem ?

This problem still exists in current 2.9 version :slight_smile: But I’ve noticed that Clément has noticed it already and, as such, I expect it eventually appears mentioned here as fixed.

Okay i recorded several videos of this problem in action.

I’m using Blender 2.83.2 with my own .blend file.

The fully packed .blend file is here:
https://drive.google.com/file/d/1ts0PkV3hEORE1YQXl-BDtupFgvlFVbq_/view?usp=sharing

I’m including it so people can debug it if possible.

I have a series of three youtube videos capturing what occurred. Note, this .blend file takes 30 seconds to a minute to load on my machine (64GBs, Intel Core7, Nvidia Quadro 4000, Win10)

go here to see the bug in action. Each video has some description as to what you are seeing:

Part 1: https://www.youtube.com/watch?v=8560WsF42Lo
Part 2 and 3 are right after this one…

Basically the summary is the following:
0) the file is 2GB in size so its takes a minute to load everything

  1. the .blend file has been saved with Eevee as the renderer
  2. go into material mode and everything is white
  3. turn off most (or all) of the collections
  4. IMPORTANT: Turn off the collection named “New Lawn” as this has a particle system on it
  5. start turning collections back on in the viewport and materials sometimes appear as normal
    but most of the time come back white
  6. if step #5 resulted in more ‘white out’, then switch renderer to Cycles
    • then turn off everything and turn back on and you will see materials back

At this point, if you render in Cycles (render in the viewport, not F12), things work

If you go back to Eevee and go into viewport render mode, immediate crash.

This has to be a bug… What else can I do to help verify it?

thanks

forgot to mention… the particle system on “New Lawn” collection was created by GrasWald3D Pro.
So i guess unless you have Graswald3d on your blender you won’t be able to render it/see it.

in that case, perhaps just create a simple plain with some particles on it to stand in its place?

I’m now seeing this in other projects… its unclear what is triggering it. I thought perhaps it was due to Graswald or some other subtle problem with the particle systems, etc. However, i have other projects that use the same assets and don’t get the ‘white object of death’ effect.

Its almost like Blender isn’t compiling the shaders and just quits. I’m upgraded to Blender 2.83.4 and see the same issues.

would love to hear any thoughts from anyone

I have the same issue with graswald :worried:

I’ve had this issue in 2.83xx with particle systems.

Switching off and on the collection which has the particle system(s) in it is the only thing that works for me. Problem still there on 2.83.5, it’s annoying but the solution is very simple.

Dude this is incredible solution for this weird bug. :open_mouth:

i just tried it extremely fast after i read your message and it WORKED.!!! omg :))))

i was having this problem for days and i could only render in cycles mode. There is a big problem with Eeve. They should fix it asap. Its very annoying and there is no pure solution like yours on the internet. you saved my huge project :smiley:

Thank you

1 Like