Materials emitting pink with no texture

Working on a file I’ve been doing for a week or so, and suddenly this

Has now become…

(I save multiple versions, pink is on a more recent one with more stuff)

The scene is large and many seemingly random unrelated parts have gone this colour. Not just whats in the screenshot.

I have tried re-loading the textures from source into the material but nothing changed. Anyone know what’s going on?

The pink color means missing texture. So you probably textured that area and then move your files to a different location and Blender doesn`t recognize your file path.

To be honest, this looks more like there is a mesh (with a missing texture) that used to be hidden and is now visible.

Yeah. What ever the reason for it’s sudden appearance, pink is usually the default when a texture can’t be found in the specified path.

Hi guys, thanks for all the replies! I have removed and re-added the image from source, nothing has changed. So instead I tried selecting 1 object rendering pink, and then selecting inverse and deleting (minus the camera).

So this does kinda suggest what was said about hidden objects. However I have made sure every single item in my scene is not hidden, and moved the post, nothing there.

I have tried deleting objects randomly, and this has caused changes. In my scene there is a small model of a light using both a diffuse and an emission material.

It’s small and out of the way, has been in my scene for days without causing problems. It has not been changed in anyway recently.
If I delete this object, then I get the following change:

I wondered if this could be a memory issue, but blender says

I have 2gb card, and 4gb ram so I think it’s not this either?

Could you try using a more recent version of Blender? 2.73 was released early 2015…
Do you render on GPU or CPU?

And how many textures are in your scene? IIRC there was a limit on the texture count available for GPU rendering. If you exceeded that, the additional textures rendered as pink, which might explain why deleting objects makes some textures reappear.

Thanks. Switched to CPU and it works, must be the texture limit. I have a HUGE number of textures in the scene. I suppose there is no alternative solution beyond:

carefully hiding what I don’t need for each render since there is a lot of hidden stuff depending on my camera position

using CPU

I think I might have read that the texture limit was raised with newer versions of Blender.
Perhaps worth trying 2.78a?

You are right again! Thanks for your help, entire scene rendered no pink in sight with latest version