Materials import with surface set to "None" - Cycles

I’m having an issue when I import objects (in this case, FBX) and all materials have a surface setting of “None”. In Cycles, they appear black.

However, when I change it to Diffuse BSDF or Principled BSDF it appears correctly.
Is there a setting to automatically detect/assign Surface on import?

FWIW the materials show up properly in eevee.