Materials on mulitple object doesnt have the same scaling

What am I doing wrong? I am trying my best to have the same scaling on some procedural tile material. but it shows completely different. I tried applying scaling and all that but still no help. Then tried to google the issue but there isn’t anything out there. Maybe i did some wrong search who knows.

Screenshots or .blend please.

How to post a screenshot? or the blend?

For example this:

Here you go.

The three different tile sizes is the same material.

Show shader nodes.

Here it is.

I can’t see from this image to what the Vector input value is connected.

atrium house small.blend (4.3 MB)

Here is the blend file.

For tiles I use Texture Coordinates/Object -> Color Mix Multiply for Color1 input. Color2 input gets 1/tile size in meters. Checker and Brick textures should have 1 as scale.

You are not providing any input for mapping.

You should unwrap them and use UV as vector input.
Without unwrapping you can try with object or generated.

Now this is just giving me a headache just for looking at it.
You are picking UV vector as mapping one but you multiply it with… brick texture? Which has no vector input.

Anyway, only circled one is UV-unwrapped. Others do not have any UVs available. You have to unwrap them.

Thank you so much. I am still learning after all this years.

Also, for my approach to work, you have to apply object scale.