Materials to work with GLSL and MultiTexture

I want my game to able to work with GLSL and MultiTexture, since according to a poll on these forums, 15% of graphics cards don’t support GLSL.

I want to have one file that work with both GLSL and MultiTexture. There are some normal maps involved. When I set the game to MultiTexture, the normal maps show up and it looks blue/purple.

How can I make my materials so that in MultiTexture the normal maps don’t show up, while in GLSL they are used as normal maps?

Thank you!

just open the Uv image editing press tab and youll see that the map used for the multitextures is the normal map, now simpli change that image by the diffuse image and wjen you start the multitexture render the difuse ll appear instead of the normal

I had tried that, and it didn’t work.

I’ve noticed that if I go to the materials texture panel and delete the normal map texture, it works, but then the normal map doesn’t appear in GLSL. Do I need to create separate UV Textutres?

Also, in the 3D view it shows like it should.

its what I said, you should check what you are doing, for me allways work, maybe you didnt understand exactly, if you want a blend i provide can provide

No matter what I seem to do, it never works right. Here’s an example .blend.

Augh! Too big to upload. Here’s the link on rapidshare. It says it can only be downloaded 10 times, so if anybody wants to look at it, but it’s out of downloads, just post here.

the “good” way is to have a “menu” file, with the desired options ( MultiTexture - GLSL) that will load a MultiTexture file or a GLSL file!

I would like to have one file that works with both GLSL and MultiTexture. That will keep the file size lower, and make it easier for me to change things.

Also, why is that considered the “good” way to do it?

1 - you dont need one UV for each texture that you use.
2 - your mesh was bugged by your material with that two UVs that s why you have that error.
3 - I just deleted the material recreate an unic UV and I had to change the position of the layer materials too, that is a mistery for me!
4 - if you want to create a lightmap you ll have to make a new UV otherwise keep just one.
Here is the fixed link if you have more doubts just ask and i ll try to answear.
good luck!


Thank you!!

1 - I wasn’t sure, so I just tried it.
2 - The bug wasn’t caused by having two UV textures, because I didn’t add the second until after I posted this topic. I wanted to try and see if that was the problem.
3 - The UV Unwrapping is a mystery to me also! That’s why i appended your material to my old object, and that way i could keep the UV Coordinates.
4 - I have no want for for a lightmap lol.

Could the bug be caused by originally making this object in 2.48, then transferring it to 2.49?

Again, thanks so much!

well mayb, i really dont know i deduct that, bad deduction hu! ehehehe.
the problem is solved and this is what you needed.
Good luck with your project!