Materials with alpha textures (GPU vs CPU)

Hello everyone! I’m experiencing a strange problem, that is connected with rendering using GPU. I know that it is still some sort of expermiental for Radeon videochips, but still. I have Radeon R7 260X 2GB and there’s obviously a great difference in speed, comparing with CPU. The artifacts, however, can not completely satisty me.

When rendering with CPU everything’s all right, but while switching to GPU some square parts of the image are darker (it is of equal size with render tiles - 256x256). I can’t understand the reason for most of it, but dark square around the dirt on the floor and on the wall are due to the alpha channel. It somehow renders or cast shadows not from the alpha outline, but from the whole plane.

I tried to look for topics with the same problem. Most of it are already outdated and dated back to 2014 - the time when AMD GPU rendering was not officially supported.

Thanks for help!


Transparent shadows are not supported with OpenCL rendering
See https://www.blender.org/manual/render/cycles/features.html

So can I turn the shadows off from transparent materials completely? I thought about that, but couldn’t find a particular solution

PS: got it - you can deactivate shadow in object settings panel