Matspider control for blender/lifgtflow


(Enzoblue) #1

This is for Eeshlo, but I posted because I hope it helps someone else too.

So far, the only way I can get any Matspider materials into the script without copy and paste is to name the material of my object with the matspider name, (i.e. Woodness_SPID).

To test this, I have made a simple cube to be used as a room with the camera inside and some lights, and I want to texture the inside of the cube.

You tell in your docs that I can name an Empty or an object and use that to rotate/scale etc the textures, like Woodness_TEXC. I tried to name my cube Woodness_TEXC and it did nothing, made an empty and named it, nothing happened. The using of different Blender sliders to adjust the color etc of the texture sounds fun, but I kinda want to get past this first.

So I guess I need a dumbed down mini tute as to how I get the material from Matspider to the inside of my cube. Do I make the object name of the cube Woodness_TEXC ? If so, it doesn’t work. Do I need to make an empty named Woodness_TEXC ? If so, how do I get the material to stick to the cube so to speak?

Nothing I have named Woodness_TEXC has imported the Matspider material into the .py.

Naming the cube’s material Woodness_SPID works, but I can’t scale the testure or anything, I have to rotate the cube to get the good-looking side to face the camera.

All aside I’m loving the script, hehe. Getting alot of stuff done now, just wanted to get more creative with textureing.

Thanks in advance Eeshlo :slight_smile:


(eeshlo) #2

By default the object itself already controls the texture size, so changing the same object’s name will not change anything. You should add another object, although I say any object will work, which is true, it is of course better to just use an empty, no need to add extra geometry to the scene. So, add an empty to your scene, name it matspidermaterialname_TEXC, rotate, scale, position the empty and that should be it. I just tested it again (for the xxxth time, you don’t know how many testrenders I did to test all these things when writing the script :-? ) just to make sure, and it still works…


(Enzoblue) #3

k, maybe I’m dumb. I tried everything tonight 'cause I can see this bugs you. If I put a single cube and light in and add an empty in and name it Woodness_TEXC like ya said and scale it around the cube, nothing happens. The script doesn’t even show the empty anywhere. Do I have to add a material and texture to the cube and put the empty name in the ob of the texture? Cause I tried that too. I also tried putting the empty name in the ‘linked object coordinates’ part of the cube’s material. Nothing happened.

I tried naming everything in the scene with _TEXC and it never came up in the script, even named the cube itself, it’s material, it’s tex, nothing worked.

I also went back into Matspider and redid your tutorial nice and slow.

P.S.
If you don’t know because it might be my setup or something, that’s cool. I’ll just fight with copy and paste etc.


(eeshlo) #4

I would have to see your blendfile to find out what is happening, but I can’t see no reason why it shouldn’t work. So, just for you, I spent the whole day creating this spectacular scene to demonstrate the texture controlling principle. Ok, maybe not, just a simple cube, but if this really doesn’t work for you, I don’t know what is happening.

http://mysite.iptic.com/eeshlo/texc_example.zip

To be sure, I recreated the basicwood from the tutorial, so copy that to the matspider library directory, then just load the blendfile, start the script, and just hit export and render. Try this a few times changing the rotation, scaling or position of the empty, that should show some changes, I really hope so at least…

edit: After reading again what you said, I think I know what is wrong, you seem to be confusing things, the object needs BOTH the matspider material AND the empty, not one without the other, that won’t do anything, setting the name in the object field of the material doesn’t do anything either, that only works with blendfile import for regular materials.


(Enzoblue) #5

WHEW, got it.

That was it, I thought it was either use the _SPID or use an empty because there’s no mention of the _SPID extension in the matspider tute, and I tend to follow tutes with perephial blinders on sometimes.

Thanks a ton Eeshlo, sorry for for the trouble. I’ll try harder to figure it out by myself next time, but I worked hard this week and was a little edgy , grrr. Have faith that I will put this to some seriously good use this weekend though :slight_smile:

[/i]