Maximized behaviour

I have a quick question. I have noticed that Blender automatically maximizes its main window after it has loaded up. Is it possible to change this behaviour?

I’m running Windows Vista and Blender 2.48a.

You can pass an argument to Blender that tells it at what coordinate and to what dimensions you want to open it to.
I believe the syntax is

blender -p sx sy w h

where you replace sx, sy, w, and h with numbers indicating the x and y coordinates of the lower left corner and the width and height you want, resp.

You ought to be able to append the flag to the end of the shortcut link.

Why would you want that anyway?

I guess I’m just anal about my window positioning :). Pity it doesn’t remember the last position and size when you close down. Thanks for the tip though.

You’ll be happy to learn that Blender 2.5 will remember your windows size and position. You can check hints of the future of Blender 2.5 at (warning: tech demos)


If you are using a shortcut to launch Blender, go into its properties, look for the command that is used (should be a complete path to blender.exe) and add the switches to it. From then on every time that you’ll use that shortcut you’ll get Blender opening to the size that you prefer. Work with quick lauch icons too.