Maximum UV Maps per Mesh

Hi all,

I’ve hit a bit of a snag with Blender, I need more the maximum 8 UV Maps for one of my mesh’s. Is there anyway to change this limit? I’ve checked the forum and gone through Blender preferences a couple times, but couldn’t see anyway to modify this limit.

Thanks!

What model is this for? Why do you need more than 8 Uv sets?

Its for a game character mesh… The texturing extension we’re using essentially allows us to have 100’s of 2k/4k textures on a model with minimal draw calls and very little texture memory load among other things. We’ve tried alot of work arounds with various problems in each approach being encountered at runtime so I won’t write an essay about those, but my next approach is to break our mesh into approx 30 2k uv maps to get all the detail from our 20million+ vertex painted hi res model onto our low res. Hopefully addressing the problems I’ve encountered with multiple materials on one UV, multiple objects, etc etc. If it’s not possible then I’ll look at some other ideas, but I was hoping there might be a setting hidden away in Blender somewhere that would allow me to test my multiple UV’s theory.

Hi

Where did You read that.

Here is a plane with 16 face and 16 UV’s…One Mesh.


I don’t know what the limit is but it isen’t 8…:slight_smile:

Tai

Time to upgrade from 2.49b perhaps?

EDIT: yeah, that one was a big brain fart, the limit is still there :o

use latest bl 2.74 may be!

2 tricks

combine UV
or define more materials

happy bl

I’m using 2.74, but it doesn’t let me use more then 8 UV maps. Materials/textures, as many as I want but UVs, only 8.


Although the [+] button is still enabled, I can’t add more UVs.

I think in bl it is limited to 8 UV map per material

happy bl

Hi

Sorry I was wrong…I didn’t get it right first time…Read to fast I think…Cheers

Tai

Well… Thought Blender limits the number of UVs you can have, it’s still possible to have (at least in cycles) all the UVs you can think of.
Just bake every UV channel into an image, and use those images as vectors for the textures.
Note that you have to change the color space of the UV image to ‘Non-Color Data’, to keep it correct.

Thanks for all the suggestions guys, I am running the latest Blender Vers. and the limit is still there. I managed to get around the issue by dividing all my uv islands into separate spaces on the one UV map using the grid for alignment and then exporting out an obj to bake one massive texture and normal map via xnormal. Then I rescaled and centered all the islands and exported another obj for import to our game. Last step was to use photoshop to cut the huge texture and normal maps into 2k chunks. It might have been a roundabout method but the result was perfection without any of the issues I’d been experiencing at run time previously. :slight_smile: