Maya Ascii camera export script

Thanks for all the comments.

Yeah I’m going to try and get proper hosting soon. I never really used my web space so it’s an old dumping ground I use now and again.

I tried the video again and it downloaded ok for me. You have to right-click the link and download it. Anyway, it’s not a video worth downloading. It’s basically the image you see in the first post but the camera is moving around. It’s only 10 frames or so.

Scuse the metoo, but…
OSXRULES RULES!!!

AAAAAAAAAAAAAAAHHHH!!! wesome.

I’ve made this weirt test with the 2d to 3d tutorial (that one of the cat in the middle of the room). So, i’ve taken a 2d photo to a 3d model, then i’ve captured mouse movement to make wiggle the camera, then i’ve exported a .ma and i’ve added some kittens on the room in After effects… GREAAAAAAAAAAAT!!!

I’ll never thank you enough Osxrules!! whatever you need and i can do i’m here! :D:D:D:D:D

Im very new to Blender, but very familiar with AE. When running the scrip brings up an error "ImpotErro: No module named Tkinter.
I also get a message when I start up Blender “Compiled with Python 2.5.
’ import site’ failed; use -v for traceback
checking for installed Python… No installed Python found.
Only built-in modules are available. Some scripts my not run.”

Can anyone advise me as to what I need to do to resolve this.
Thank you in advance for you help.
As I said I’m very new to Blender, about a day and a half into learning it.

Well, i think that you need to install Python in order to get this script (and a lot of others) running.

Thanks for that, works great.
really appreciate the work in making the ma. exporter.:slight_smile:

Ok… I’m pretty new to the whole 3d stuff but have been playing around with it a bit. I have AE 7 and I am trying to import the camera data using the ae script provided in this thread. Every time I try to import the *.ma file AE crashes on me. :confused:

Any ideas?

EDIT:
I’m using blender 247 and python 2.5.

EDIT#2:
Ok I figured it out… I only have AE 7 and AE 7 Pro is required to read *.ma files. Too bad for me I guess… :wink:

hello, i can´t use it with AE CS3; is it me or we would need an update???
hope u can update it soon, this scripts seems wonderful.
thank you

Edit
It imports everything from the scene (camera traking???) , but as null objects…

pablow: that’s how it’s supposed to work i believe.

And thanks osxrules, I used this last week to export some complex camera moves to a client using after effects and it worked great.

pablow: Yup, works fine in CS3. You use the nulls to give you position information for placing AE elements.

This has become one of the essential scripts for me.

For me too. :wink:

Just wanted to thank you osxrules for this great script!
I’m trying it and I’ve seen that the only coordinates animated object it exports, besides the camera data, are the nulls. Now, it would be cool if it could exports the transform properties of other objects on the scenes. Since now one have to parent a null to the animated object to export.
Anyhow, thank you again for this cool add to my Blender tools.

Blender tells me there’s no python being installed - I took Python 2.6.2 release and installed it.
feel pleased to help me =)

thx

What is your configuration?
Are you using any x64 version?

Unfortunately I’m runnin on vista 64bit with Blender 32bit-
…I use a core 2 quad cpu, 4 GB RAM…
(would you recommend windows xp(64bit) ?)

Just wanted to check if the problem is the python version you’ve installed…
I’ve got some trouble when I installed python x64.
I’m on win7 x64 and I’ve installed python x32, no prob. now.
Also, you may install as much blender version as you want: currently I’ve installed x32, x64, Kai’s rel., and a Sim Physics Branch.
But when I’ve to run this script I usually do it within the official blender x32.

Hope it will fix your problem!

hm… I’ve tried the x64 version of blender- nothing
I’m a newbie in 3D things… but just to have a good setup with the prog is that difficult- arrh
(win7 ? already available?)

by the way- nice work + page

What I meant is this (if you already have blender configured as described below then I don’t know what could be the problem):

  • install blender x32
  • install python x32
  • copy the script inside the usual folder (…\Blender Foundation\Blender.blender\scripts)
  • run the script from the menu FILE / EXPORT / Camera Tracking (.ma)

By the way I’m using Python version 2.5.4
About win7 it’s a beta, if I’m right it should stop to work in July or August… but it works really fine and much better then Vista.

p.s. thanks for your comments :slight_smile:

this is it! the same problem… strange

edit: now running python 2.5.2 !! “got it!”

Just wanted to say Super Badass Props and Kudos to Osxrules for donating his time and making this script available to the community.

I use AE at work for digital signage/displays, and have always been a blenderhead/blender dabbler… this will open the gates wide open to motion graphics people who know AE and want to make the leap to incorporating true 3D into their work without shelling out the cash for a 3D package. Not that Blender needs any help, but tools like this are what draw users to try Blender who might never have otherwise.

Can’t say Thanks enough. This is awesome.